Deploy failed with exit code 1:

Hi,

I keep having issue when trying to deploy my react project, tried everything I found in forums with similar errors but no luck. The site name is competent-banach-fb887b and the error is the following:


Thanks in advance,
Marco

Hey @Marco75

Unfortunately the screenshot cuts off the part of the log that contains relevant information to the error.

However…

it looks like there is something not quite right with the build command used. Can you try changing the build command to either npm run build or if you feel you need to set CI to false CI= npm run build.

If you are still facing issues, can you share the link to the latest deploy log and a link to the repository you are deploying.

Thanks Coleman,
I tried it, but no luck, I also tried Ci = ’ ’ bpm run build as explained in the netlify docs but did not work.

the github repo is https://github.com/marcodallomo/TravelPinApp_frontend.git

and the latest log screenshot

On my machine all works, but cannot deploy for some reason… Thanks again for your help :slight_smile:

Using the following build settings
build command: npm run build
publish directory: build
I was able to successfully deploy your code. But only after removing

import { formLabelClasses } from "@mui/material";

from App.js.

If this does not work for you, please share the link to the deploy log instead of a screenshot (the screenshots provided do not show the cause of the error, only the error itself.)

Hi Coelmay,

thanks for the message, I tried but did not work, here is the link to the log

https://app.netlify.com/sites/competent-banach-fb887b/deploys/61fd493dd1e0cd329cf011b7

Thanks a million,

Marco

I’m not sure why the deploy is running out of memory, especially as I was able to deploy the same code without issue.

Could you try deploying a new site from the same repository (no need to delete the current one) and see if the same thing happens.

Hi Coelmay,

thanks for your message, I tried to deploy a new site but had the same outcome , see the log here Netlify App

Thanks,

Marco

Hey @Marco75

I forked the repository and had the same issue on first deploy.

I then deleted the package-lock.json file and the build succeeded.

Hi,

I managed too, I used this solution FATAL ERROR: Ineffective mark-compacts near heap limit (Nuxt)

thanks for all your help!

Have a nice week end:-)

Marco

1 Like