Command failed with exit code 1: CI=false npm run build


I’m trying to redeploy a website, but this error appeared after I started refactoring the code.
I deleted the previous deployment and tried again, but the same error keeps occurring.

Deploy address:

Deploy Log:

I’m sorry I cannot explain the error well. I am still a newbie in programming! =)

Many thanks for your help,
Tulio Minini

I think your build is failing at whatever you’re doing here: Netlify App

Not sure what kind of tests you’re running, but could you try to disable those for now?

thanks for your reply.

As far as I know I’m not running any tests, so I’m not really sure how to disable it. haha
I still don’t know how to fix that! :sweat_smile:

Try removing the postbuild script: where-to-go-front/package.json at main · t-minini/where-to-go-front · GitHub


Thank you very much, it worked!

Would you know why the “postbuild”: “react-snap” was crashing my deployment?
I was using react snap to configure the meta tags in the HTML file and also to be able to use a meta image on my app, so when the website is shared on social media, it shows an image preview.

Again, many many thanks for your help.
You’re a lifesaver!!

1 Like

Thanks so much for coming back and letting us know this works! Happy building :rocket: