Deploy failed for iridescent-buttercream-6d68a3

Hello team! Hope you are well.
Sorry, I am new here and cant understand why my site was not deploying?

My netlify site name is - iridescent-buttercream-6d68a3

Production: master@[HEAD]

Deploy failed for iridescent-buttercream-6d68a3

  • Build problems
    3:25:59 PM: Netlify Build
    3:25:59 PM: ────────────────────────────────────────────────────────────────
    3:25:59 PM: ​
    3:25:59 PM: ❯ Version
    3:25:59 PM: @netlify/build 29.11.8
    3:25:59 PM: ​
    3:25:59 PM: ❯ Flags
    3:25:59 PM: baseRelDir: true
    3:25:59 PM: buildId: 647dd441b4dccc00891157e0
    3:25:59 PM: deployId: 647dd441b4dccc00891157e2
    3:25:59 PM: ​
    3:25:59 PM: ❯ Current directory
    3:25:59 PM: /opt/build/repo
    3:25:59 PM: ​
    3:25:59 PM: ❯ Config file
    3:25:59 PM: No config file was defined: using default values.
    3:25:59 PM: ​
    3:25:59 PM: ❯ Context
    3:25:59 PM: production
    3:25:59 PM: ​
    3:25:59 PM: Build command from Netlify app
    3:25:59 PM: ────────────────────────────────────────────────────────────────
    3:25:59 PM: ​
    3:25:59 PM: $ npm run build
    3:26:00 PM: > react-weather-app@0.1.0 build
    3:26:00 PM: > react-scripts build
    3:26:01 PM: Creating an optimized production build…
    3:26:04 PM: One of your dependencies, babel-preset-react-app, is importing the
    3:26:04 PM: “@babel/plugin-proposal-private-property-in-object” package without
    3:26:04 PM: declaring it in its dependencies. This is currently working because
    3:26:04 PM: “@babel/plugin-proposal-private-property-in-object” is already in your
    3:26:04 PM: node_modules folder for unrelated reasons, but it may break at any time.
    3:26:04 PM: babel-preset-react-app is part of the create-react-app project, which
    3:26:04 PM: is not maintianed anymore. It is thus unlikely that this bug will ever
    3:26:04 PM: be fixed. If you are starting a new project, you may consider using
    3:26:04 PM: maintained alternatives such as Vite ( instead.
    3:26:04 PM: Add “@babel/plugin-proposal-private-property-in-object” to your
    3:26:04 PM: devDependencies to work around this error. This will make this message
    3:26:04 PM: go away.
    3:26:07 PM:
    3:26:07 PM: Treating warnings as errors because process.env.CI = true.
    3:26:07 PM: Most CI servers set it automatically.
    3:26:07 PM:
    3:26:07 PM: Failed to compile.
    3:26:07 PM:
    3:26:07 PM: [eslint]
    3:26:07 PM: src/App.js
    3:26:07 PM: Line 19:11: Using target=“_blank” without rel=“noreferrer” (which implies rel=“noopener”) is a security risk in older browsers: see About rel=noopener react/jsx-no-target-blank
    3:26:07 PM: ​
    3:26:07 PM: “build.command” failed
    3:26:07 PM: ────────────────────────────────────────────────────────────────
    3:26:07 PM: ​
    3:26:07 PM: Error message
    3:26:07 PM: Command failed with exit code 1: npm run build (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
    3:26:07 PM: ​
    3:26:07 PM: Error location
    3:26:07 PM: In Build command from Netlify app:
    3:26:07 PM: npm run build
    3:26:07 PM: ​
    3:26:07 PM: Resolved config
    3:26:07 PM: build:
    3:26:07 PM: command: npm run build
    3:26:07 PM: commandOrigin: ui
    3:26:07 PM: publish: /opt/build/repo/build
    3:26:07 PM: publishOrigin: ui
    3:26:08 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 2 (Search results for '"non-zero exit code: 2"' - Netlify Support Forums)
    3:26:08 PM: Build failed due to a user error: Build script returned non-zero exit code: 2
    3:26:08 PM: Failing build: Failed to build site
    3:26:09 PM: Finished processing build request in 29.367s

Thank you in advance! :heart:

Your build is failing because the default behavior is that warnings are treated as errors.

The easiest way to disable this is to change your Build command from npm run build to CI= npm run build.

This will set CI to false.

You can read more about it here: