Deploy failed due to "Host key verification failed"

Hi, I have a project which was running without any issues previously. Haven’t touched it for a few months and back on it now. During “Branch Deploy” npm install is failing with:

12:56:58 PM: npm ERR! Error while executing:
12:56:58 PM: npm ERR! /usr/bin/git ls-remote -h -t ssh://
12:56:58 PM: npm ERR!
12:56:58 PM: npm ERR! Host key verification failed.
12:56:58 PM: npm ERR! fatal: Could not read from remote repository.
12:56:58 PM: npm ERR! Please make sure you have the correct access rights
12:56:58 PM: npm ERR! and the repository exists.

When I run the build locally there are no issues. I’m wondering why on netlify the package get’s loaded via ssh? It’s also a public package. Does anyone know why this issue is coming up? My project repo is hosted on gitlab. But if I understand it right the build is taking place on a netlify server, so the repo get’s cloned and the install process is taking place on netlify. Not sure why a key and where a key would be needed.

hi there,

you say that : " My project repo is hosted on gitlab. " but the link in the code above is to a github repo:


can you clarify this a bit for us please?


Hey Perry, yeah my project is hosted on Gitlab. But the one which caused trouble (ssh:// loaded with “@esri/react-arcgis”: “^5.1.0” is external. However, I tried again last night and now the error does not appear anymore during built. Something must have been resolved in the meantime.

1 Like