Deploy failed due to an error in @netlify/plugin-deploy-core plugin

Hey folks, I’ve just started receiving these errors when building. It seems to coincide with enabling Algolia, but that happens post-build. This seems to be erroring earlier?

these are the plugins i have installed:

  • Algolia Crawler by algolia

  • No More 404 by sw-yx

  • Sitemap plugin by netlify-labs

Can now produce consistently.

6:36:54 PM:   Error location
6:36:54 PM:   In "onPostBuild" event in "@netlify/plugin-deploy-core" from core
6:36:54 PM:       at handleDeployError (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins_core/deploy/buildbot_client.js:77:9)
6:36:54 PM:       at deploySiteWithBuildbotClient (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins_core/deploy/buildbot_client.js:65:12)
6:36:54 PM:       at processTicksAndRejections (internal/process/task_queues.js:97:5)
6:36:54 PM:       at async onPostBuild (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins_core/deploy/index.js:20:5)
6:36:54 PM:       at async Object.run (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins/child/run.js:17:3)
6:36:54 PM:       at async handleEvent (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins/child/main.js:34:38)
6:36:54 PM:       at async process.<anonymous> (/opt/buildhome/.netlify-build-nvm/versions/node/v12.16.3/lib/node_modules/@netlify/build/src/plugins/ipc.js:103:16)

hi there @lukeoliff!

Sorry to see you having trouble.

Could you please follow the steps outlined here to get you some support from algolia?