Home
Support Forums

Deploy failed due to an error in netlify-plugin-cypress plugin

Hello everyone,

I am new to netlify and am having the following error preventing me from deploying my site on netlify.

I have tried reinstalling the cypress plugin and am still having the same issue. Any help would be much appreciated.

Hi @kent28 , welcome to the community! :wave:

I believe you opened a helpdesk ticket on this and was able to workaround the issue by switching build image to Ubunto 16.04.

Hi Audrey,

I ended up using gatsbyjs cloud to deploy and it worked.
However, if i did want to use netlify, is there a solution or workaround for me to deploy my site based on the error shown above?

Hi @kent28 , sorry I had you mixed up with another customer who wrote into our helpdesk with almost identical question! :grinning_face_with_smiling_eyes:

The workaround at the moment is to switch your build image from Ubuntu Focal 20.04 to Ubuntu Xenail 16.04 in the UI:
Site settings > Build & deploy > Build image selection

Let us know if that worked!

2 Likes

It worked thank you! I noticed that the cypress plugin still crashed during the deploy though. Will this be a problem for future builds?

Thanks for suggestion i think this is helpful and solve my issue.

1 Like