Couldn't find package

I am getting the below error while deploying my first site in Netlify

error Couldn’t find package “@organization/reponame” on the “npm” registry.
info Visit yarn install | Yarn for documentation about this command.

my .npmrc look like below


I saw few postings related to this
Some saying to have a token in npmrc, But I don’t have a token to place it in Netlify Environmental variables

help me on this

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile: Additionally, this Support Guide houses all of our resources for debugging build and deploy issues.

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

We are an organization, We do have multiple application deployed in Netlify already. This time we are dealing with internal packages.

Here is the package.json look like

"dependencies": {

    "@Organization/package1": "0.0.16",

    "@Organization/package1": "0.0.4",

    "@Organization/packge-footer": "^0.1.14",

    "@Organization/package-header": "0.0.3",

All these packages are private git repositories

Here is how my npmrc look like


When I run npm install locally, Everything is working fine,

But when I try to deploy it in Netlify, There the packages are getting failed

Below is the error

error Couldn't find package "@Organization/package1" on the "npm" registry.

Error during Yarn install

I don’t have auth token in my npmrc, I see some solutions with auth token

The forums didn’t answer my exact issue properly, I am okay to have a session to fix this

Please help me on this

I think you need one.

There’s more info here: