Connected existing Domain with Netlify (set NS-Record). Now I no longer recieve E-Mails

Hi everyone,

working as a UI-Developer most of the time I have a hard time understanding a problem I currently face.

So I have my domains registered at a german web hosting company ( Couple of weeks ago I decided to move my website from there to netlify. For that I had to set the NS-Records at to the ones netlify uses. Connecting my domain with netlify worked.

But since I connected the domain, I no longer recieve E-Mails to it nor can i send E-Mails from the domain.

What did I miss? Is this issue even answerable or is that to specific and needs more details/investigation?
I’m suspecting that I just missed something obvious …the dev ops noob that I am.

Thanks for every hint & help

Hey lars, moin moin.

Congrats on getting your domain set up! You will likely find this post helpful:

moin perry,

wow. thank you VERY much!

lars :slight_smile:

1 Like

hi perry, thanks again for the helpful step by step guide in the linked thread.
I still have a problem with finding the right server path for my mail service. I’am currently trying it with which i think does not work.

I really cant get much info out of I cannot access the MX-Records page there because I set the NS-Record to a custom url (netlify).

My guess would be that it isn’t working because the imap address is for configuring your e-mail client … it’s not the domain of the mail servers.

Check with to see what domains they use for mail servers. You may be looking for a domain name that looks something like or

Hi, @lars. I think the issue you are experiencing is described here:

Please look for this second on the page above:

I did not copy my records before switching name servers and my email (or other service) stopped working. How do I fix this?

If the solutions there don’t work or if there are any questions, please let us know.

1 Like

Hi @lars , did you manage to solve it? I am also trying to figure out what mailserver value to input on Netlify MX dns record. I can’t find any relevant info by looking at my dashboard on

1 Like

Hi, I would also be interested how you solved this. Thanks for sharing.

I added a bunch of MX Records to Netlify. Using, and finally After adding it finally worked.

I’d like to add that it could also be that the previous entries needed some time to “adjust”.

1 Like

Your right, it is possible that DNS propagation has a part to play in this. Glad you got it working :slightly_smiling_face: :netliheart:

OK seems to work for Strato. May I ask, where you found that piece of information? I searched “everywhere” and did not find any information about this.

Did you set a TXT Record as well?

Hi, @nilsbinder. If you want to copy the existing records to Netlify, I believe these are the instructions to find the current records there:

Note, using Netlify DNS isn’t a requirement. You can also use the external DNS instructions instead:

If you use those instructions you don’t need to copy anything to Netlify because you are keeping your existing DNS service.

​Please let us know if there are other questions about this.

Thanks for your answer.

As far as I understand, there is one problem:
The Domain I registered is a .de domain and it is not supported for Netlify DNS, so I have to set the Records manually. In the GUI Provided by Strato, there is already a MX-Record, but it will not show the Details. It only tells you something like “Use Strato Mail Server”. I got everything working by adding to my MX-Records, but it feels a little like … well magic.

As I have no insight into what happens at Strato, I cannot explain it myself.

If there are any questions about configuring your DNS to use domain names with sites at Netlify, please let us know and we will be happy to answer.

Hi Nils,

Thanks for the Question. Luckily I had a working E-Mail with another Domain at Strato. I managed to extract from a MX Record Checker Website (Don’t remember which one, but something like should do the trick).

edit: I did not set a TXT-Record or anything else for that matter.

By the way, I contacted Strato Support and this was their response (German):

Ihr Paket hat kein MX-Record. Damit Sie den Mail-Server von STRATO nutzen empfehle ich Ihnen einen A-Record anstatt den NS-Record zu nutzen. Fragen Sie bei Ihrem Anbieter ob Sie für Ihre Domain einen A-Record hinterlegen können.

Im folgenden Hilfe-Artikel erklären wir Ihnen wie Sie den A-Record eintragen können:
Einstellungen im Konfigurationsdialog A-Record | STRATO

Loosly translates to, my Strato Package doesn’t include MX-Record. I should contact [Netlify] to ask for an A-Record.

Honestly didn’t understand that.

Glad to help.

1 Like

May I ask for the complete settings of your MX record?

So far I got:

Record type: MX
Name: @
Priority: ???
TTL in seconds: ???

Strato Support told me on the phone today that setting up a MX record for Strato mail servers is not possible because it’s a complex system. I talked to three support reps over the past two days and the information varied greatly…

Not sure if @moritzpflueger would reply based on the age of this thread, but if it doesn’t work out, you’d have to remove Netlify’s nameservers and use external DNS or change your email provider.

1 Like

I’ve used 5 for priority (I got that value from and the default value for TTL. Everything seems to be working fine for now. We are not using Exchange (= Strato E-Mail Premium Plan).

Thanks for the help! Kinda funny that it was so easy, and Strato Support told me it’s impossible because of their complex setup :joy: