Command failed with exit code 127: nmp run build

I have serached the forum but found similar issues that do not resolve my issue.
I have tried to deploy my site and failed:
got this:
7:41:36 PM: 1. Build command from Netlify app
7:41:36 PM: ────────────────────────────────────────────────────────────────
7:41:36 PM: ​
7:41:36 PM: $ nmp run build
7:41:36 PM: bash: nmp: command not found
7:41:36 PM: ​
7:41:36 PM: ────────────────────────────────────────────────────────────────
7:41:36 PM: “build.command” failed
7:41:36 PM: ────────────────────────────────────────────────────────────────
7:41:36 PM: ​
7:41:36 PM: Error message
7:41:36 PM: Command failed with exit code 127: nmp run build (Search results for '"non-zero exit code: 127"' - Netlify Support Forums)
7:41:36 PM: ​
7:41:36 PM: Error location
7:41:36 PM: In Build command from Netlify app:
7:41:36 PM: nmp run build
7:41:36 PM: ​
7:41:36 PM: Resolved config
7:41:36 PM: build:
7:41:36 PM: command: nmp run build
7:41:36 PM: commandOrigin: ui
7:41:36 PM: publish: /opt/build/repo/dist
7:41:36 PM: publishOrigin: ui

Should I change my command: nmp run build? But for what?

hi marta,

looks like you have a typo. its npm not nmp. We encourage all kinds of questions here, but please do try basic troubleshooting and a simple command accuracy review before posting, its appreciated.

if you have further questions after this, do let us know.

Than You for your advice. I am beginner. Just learning coding.
I corrected the command .

Now I have this issue:
Deploy did not succeed: Deploy directory ‘dist’ does not exist.
I have tried rename the Base directory with the name of my project but it is not working.

I reloaded my site from github again. And it is ok now.
What helped me is when I deleted the command and directory name while reloading. And now it is working. It has deployed. Maybe this post will help someone who is beginning just like me.

Hi again marta, of course beginners are very welcome here.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile: Additionally, this Support Guide houses all of our resources for debugging build and deploy issues.

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!