Command failed with ENOENT

site name =

hey, you can reproduce the error when you go to

(or change the v parameter with any youtube video, you will get the same error, I didn’t get what is the problem, is it because of the youtube-dl-exec package ?

You need to download the binary (for Linux):

Then you need to follow this: GitHub - microlinkhq/youtube-dl-exec: A simple Node.js wrapper for youtube-dl/yt-dlp.

same problem, It worked with the command line but when I execute “./yt-dlp_linux 9fAyEqgBGyU --format bestaudio --skip-download --dump-single-json” for example but it won’t when I code it.

You need to share a reproduction in the form of a codebase - maybe a Git repo.

sorry for the late reply, here’s the code GitHub - YASSlNE/YTAO_API

I spent a few hours trying this out, only to discover this:

I reached till that exact spot shared by that user.

It says, python3 not found. There doesn’t seem to be an easy way to install Python in AWS Lambda running on Node.js. So, I don’t think what you’re trying is possible.

1 Like

Okay, thanks anyway for your efforts