Can't set GitLab access token on Deploy Notifications

I’ve generated a GitLab access code to use on Netlify platform.
However, Whenever I try to setup the token on the Notifications panel -> GitLab Commit status, it looks like it went fine (No errors), but the token doesn’t get stored. If I open the form again, it’s empty.

Example Video:

Does anything happen in the javascript console or any bad status http requests shown in the browser developer tools when that happens?

Does it happen with no browser plugins/extensions running?

What browser are you using?

What site is this on, so we can try in-situ?

I ask because we managed to edit a notification like that normally on another gitlab connected site, so I think that it is something situational which I would love to dig into further once we have more details!

No errors in the console.
The PUT request to set the token goes fine (status 200).
It carries the data.access_token I inserted, but the response comes with data.access_token: null and success: true

It happens on all sites in my account. So it’s probably a problem with my account.
One example is:

BTW, I’m using chrome, no extensions (incognito mode).
But I don’t think that matters since the request carries the information fine, and the returns doesn’t.
It’s losing the info somewhere in the server.

I’m available to help any way I can.

Thanks - very much appreciate your investigating. Sad to hear it wasn’t something obvious :/.

Since we can’t create a token for you (it uses the authentication in your browser to GitLab), I guess the next question is not optimal but may be a way to resolve it:

If you turn it (git gateway) off, and then back on, does that help? (

I just disabled and enabled again git-gateway,
Generated a new token with all permissions on GitLab,
And tried to set it on the platform again, But sadly, I’m still having the same problem :confused:

The problem doesn’t seem to be on git-gateway.

This is working fine, and my deploys are working very well.

I just can’t set an access token so that Netlify can modify my commits to show the deploy status.

Hey @ighormartins, I was able to reproduce this so filed a bug about this issue and will post here when we have an update. Thanks for bringing to our attention.

Re: token not getting stored in the UI, I learned that that’s actually intended! That interaction snagged me too. But what happens is that we encrypt the token once you enter it and then, as a security measure, we don’t show it in the form field—similar to how we wouldn’t show your password once you’d entered it.

Re: notifications, we dug in a bit more and noticed in our logs that you were successfully using an updated token the other day. Did you manage to get Deploy Previews notifications working?

I really don’t think it was working. I wasn’t getting any changes on gitlab. That’s why I though the form not displaying the token was a problem.

But I’ll try it again, and let you know if it’s working or not in a bit.
Thank you.

Let us know. we were seeing your notifications have an error_rate of 0 (along with some failures in the past), which means the last send worked from GitLab’s PoV…