Home
Support Forums

"Cannot read property 'trailing_slash' of null"

Site : https://60eafd1ea3d6b10007bb0b98--suspicious-leavitt-174e82.netlify.app/
Clicking on any of the navbar links leads to the following error:

{"errorType":"TypeError","errorMessage":"Cannot read property 'trailing_slash' of null","trace":["TypeError: Cannot read property 'trailing_slash' of null"," at respond (/var/task/index.js:1794:41)"," at render (/var/task/index.js:2041:10)"," at Runtime.handler (/var/task/index.js:2359:26)"," at Runtime.handleOnce (/var/runtime/Runtime.js:66:25)"]}

I have tried to resolve this by adjusting my SvelteKit config using the trailingSlash option.

However none of the configurations’ options work: https://kit.svelte.dev/docs#configuration-trailingslash

Here is my repo: GitHub - digidub/portfolio-site

Might anyone know how I overcome this error? Thanks.

Hi @digidub

As per your previous thread Un-debuggable error , have you tried changing the adpter to static? Deployed as such as https://peaceful-goodall-2ffad5.netlify.app

Hey, thanks for checking this thread too.

I initially thought this had saved my woes, however using the static adapter renders the whole site as static separate pages. My app was previously working as an SPA with nice element transitions - check here for how it was working previously https://60dee1fd3347060008bfedb0--suspicious-leavitt-174e82.netlify.app/ and you’ll see what I mean. Interestingly enough there was no index.html output to the build directory for this version but the site still worked!

Hence why called static.

Ah, righto.

Found this that might help: Building a Svelte Static Website with Smooth Page Transitions | Codrops

So what is it that changed from then to what you have now?

So what is it that changed from then to what you have now?

This is what I can’t understand. I made some minor changes to my site and the netlify deployment stopped working! The last working repo is here: GitHub - digidub/portfolio-site at 2860de9a3f496a5ef034614caabee19c1ee0407e

Thanks for sharing the link to the static site page transitions. I’d really like to solve this the proper way and keep the SPA functionality if possible, hopefully someone will be able to chime in here with what has suddenly gone wrong to stop this working.

I tried deploying both current repo, and previous one you just shared, using Netlify CLI. Neither worked. They didn’t work locally either. At least the result was consistent, which given I can see virtually no differences between the two code bases, is nice. I suppose :thinking: