Cannot read property pid with netlify dev

Created a new folder and then scaffolded out a simple serverless function. Fired up netlify dev and see successful messages and then an immediate crash with:

TypeError: Cannot read property 'pid' of undefined
    at ~/.nvm/versions/node/v12.10.0/lib/node_modules/netlify-cli/src/commands/dev/index.js:460:1234:

This is with netlify-cli/2.23.0.

Heya @talves and sorry to hear about the trouble. Thanks for filing which I think we just landed a fix for - let me know if I guessed wrong on either count, please!

1 Like

I’m not @talves but I can confirm an update fixed it. Thanks!

1 Like

I’m @talves, and still having the issue that can be tracked here:

well, shoot - sorry Tony & Raymond! Y’all are two of our favorites and this fool got you mixed up :man_facepalming:.

I can tell you, Tony, that @DavidWells is still working with the CLI team on that issue as we can reproduce it on osx.

Hey, I don’t mind getting mixed up with @cfjedimaster (Raymond) :heart:

Heh, well if it helps, it worked for me on WSL on my Windows box.

I re-opened the issue in the repo, hopefully we can figure out why it’s not working for Tony!