Hi, I am trying to deploy a Nextjs application (hello-world.services is its name) and I get an error about the Nodejs version I cannot overcome no matter what I do. Please have a look below:
error email@example.com: The engine “node” is incompatible with this module. Expected version “>=12.22.0”. Got “12.18.0”
Thanks a lot,
Thank you for reaching out and welcome to Netlify’s Support Forum!
I see a similar issue here in our Forums. Does the solution mentioned work for you from
The build image you are using is running an outdated and incompatible version of Node.js.
Using one of the methods outlined in the Manage Build Dependencies 9 documentation to updated the version of Node.js used is the simplest.
I set the NODE_VERSION env variable to 12.22.0 and that worked!
Could you give that a try and let us know if you have any questions?
Thank you so much!!! I used NODE_VERSION: 16.14.1 and it worked!!
Hi @fakiolinho , thanks for coming back and letting us know it worked for you! We really appreciate the feedback as this will help other users if they encounter similar roadblocks. Happy building!