Home
Support Forums

Build Failed: Incompatible Module Found

I need advice to debug deploy Netlify App . I get the error that engine “node” has expected version “>12” but it only finds version “10.24.1”. I have also tried to set the NODE_VERSION environment variable, but it still doesn’t work. Any help would be greatly appreciated.

Hi @Ramneet,

Welcome to the Netlify community :netliconfetti:

You have set NODE_VERSION as per Manage build dependencies | Netlify Docs?

Hi @coelmay ! Thank you, I really appreciate the help. Yes, I think so. I’ve set a “NODE_VERSION” environment variable and put its value as 14.

Can you try this @Ramneet: under “deploys”, click Trigger deploy > Clear cache and deploy site. Possible the older node version is cached even though you’ve now set the NODE_VERSION variable.

Hi @coelmay ! I actually was finally able to build the site about 5 minutes ago. I think the issue was I had forgotten to put my yarn.lock file in .gitignore. I set the “NETFLIFY_USE_YARN” to false and that solved my issue. Curiously though, the build still used the version 10.24.1 of Node. I was wondering if you could educate me a little about why it did that and also why didn’t the build fail like it did earlier. Thank you again for your help:)

Glad you were able to get your build done. :smiley:

Likely 10.24.1 was used still because of the Build Cache.

Ah okay, clearing Cache and building also hadn’t solved my issue earlier though. Also, what I’m curious about is why 10.24.1 was causing incompatibility earlier but isn’t doing so now. Probably need to read up a little (or a lot :p) on yarn and npm.