Building website from Git hub repository: Page not found

I am trying to publish one of my Git repository to a web site. I have gone through the “page not found” error discussion and guessing I have only two files in my repository- “R-Basics.html” and “” that might be insufficient for netlify to deploy. Do I need to have index.html file or change some build settings? If yes, please let me know a step by step walkthrough how to make necessary files in my repository so that I can publish it as a netlify web site. I am attaching a postbuild screenshot.

The issue as outlined in [Support Guide] I’ve deployed my site but I still see "Page not found” is you do not have an index.html. Try renaming the R-Basics.html file to index.html.

1 Like

Thank you. It worked!!

Considering the repository structure described in my earlier post, my next question is how to add more webpages to my website? I tried uploading another html file but it does not straight way show up in my website. I am sure there is something more I need to do to tell Netlify how to show up other pages from my published repository.

The repository structure is basic. I see not reason why the new file would not get deployed or why you cannot access it.

Can you share the URL for your site?

Yes, here it is. It is a simply written tutorial rendered by R markdown to html format. I am guessing there is no information in my index file how my website or other pages will appear.

The file is deployed But if there is no link to it from the homepage or other location, no one would ever know.

Oh I see. Can you please tell me what edits are needed to do that? How to inform homepage (index file I guess) that other pages exists and users can navigate through them?

In order to navigate between pages an <a> anchor element is required.

I have not used R Markdown or associated build tools, so I can say what is needed to produce such links as part of the build. Suggest consulting relevant documentation for the language/tools.

1 Like

Many thanks. The suggestion has worked. The site worked fine with domain.
My next trouble is-- I have transferred my domain ( bought on google domain and I see domain status as “primary domain” with a green tick next to it and I can also see the new domain name “” is successfully displayed in the domain management section of netlify. However, I still get “site can not be reached” when I open

Works for me

O I guess something wrong with my browser configuration/wi-fi security then. I tried fixing some settings in Google chrome but nothing worked. I tried safari but did not work either. Any clue?

Without sitting in front of your computer, no.

You could try clearing your browsers cookies and cache.