Build-image "opt/build-bin/build: Operation not permitted"

Netlify site:

I am getting an operation error with Netlify’s build image.
My sex2 project is clean with nothing to commit.
I have followed the instructions in the repo’s readme and get this error:

➜  build-image git:(xenial) ./test-tools/ /Users/•••••••/Documents/GitHub/sex2             
buildbot@de8d24a3bdc2:/$ /opt/build-bin/build npm run build
bash: /opt/build-bin/build: Operation not permitted

I am running:

  • Mac OS 11.3.1
  • Docker Desktop 3.3.3
  • netlify/build xenial

There doesn’t seem to be much discussion in the forums about the build-image so I hope this is still relevant!

Cheers :zap:

Hi there, @taz :wave:

Thanks so much for reaching out, and welcome to Netlify Forums :netliconfetti: I see that this thread has been a bit quiet since you posted this question. Are you still encountering the same error?

If so, let me know what else you have recently tried and I will see if I can get some eyes on it. Thanks!