Build failing with non-zero exit code 1

Briefly summarize the issues you have been experiencing.
Hey all :wave:, while building, I get non-zero exit code 1 while webpack is processing some lodash modules from node_modules. Weird because I have a project using an identical webpack/babel config that builds without issues on Netlify.

Please provide a link to your live site hosted on Netlify

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

  1. Building locally works fine
  2. Building projects with similar/exact webpack configs work fine on Netlify

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?

^ Logs attached above

Hi @kysley, If you clone the repo in to a new directory and run yarn to install the dependencies, then run your build command, does it install and build as expected?

Hey @futuregerald, just tried this. Everything installs and builds as expected when cloning into a new directory :face_with_monocle:

seems like you got it worked out in the meantime? You have a few successful builds at the top of your deploys list now. Enquiring minds would love to know what the fix was (or if this fool guessed wrong ;))

(looks like my reply from the weekend got ate up somewhere in the internet) So– yup! your suggested fix ended up letting the actual error bubble up.

edit: the fix came from your reply to my email. Said fix was

remove --progress from your webpack build command

Interesting enough, the error that was causing gripe on your build vm’s wasn’t present on my local machine- but nonetheless i was able to solve the issue :)) Thanks for continuing to be the best!

1 Like