Broken links when deploying a gatsby website

I am building a POC using gatsby (
It used to work fine, but from some time all the internal links are broken.
They work fine on both my local develop and production builds, and they did use to work on netlify as well.
On the deployed version, I can see that the relative path I coded in, is added to the URL of the current page, and not to the root as it should be. So for example, from the page instead of having the link is built to point to
I have tried to use gatsby Links, gatsby navigate (through a call back function) and plain HTML tags, and I am always getting the same results.

I cannot find a way to even work around this and I am sure they worked until recently (using gatsby Link)

Any suggestion?
Thanks a lot for your support

I have figured that out.
I thought the path was relative to the root, but it looks like it is relative to the current page. So I had to add the double dot at the beginning as in …/alerts
It is confusing, because of the inconsistent behaviour on different builds even on the same platform.