Blank page when trying to browse /admin


We have a netlify site running at:

However, we have just detected that the ‘admin backend’ (/admin) doesn’t work. We can’t establish when this issue started to happen, but we know that:

  • sometime around the 7th April /admin was working
  • we haven’t made changes to the codebase that would account for such a change in behavior (the most recent changes after 7th April are adding a few lines to the file)

The admin page, although as a blank page, seems to loads (since the html title is shown in the browser’s tab, ‘content manager’. The browser’s dev tools/js console show the next error: ‘net::ERR_ABORTED 404’ for the script sources ‘react.production.min.js’, ‘react-dom.production.min.js’, ‘netlify-cms-app.js cms.js’ and ‘netlify-identity.js’

We have tried to redeploy, and the redeployment works in itself (with a couple of warnings along the lines of: ‘Plugin X is not compatible with your gatsby version’ )

We have also tried to disable/enable the Git Gateway, to no avail (currently sits as disabled).

Do you think the above information is enough to help us determine what is the issue? If there is anything else that I need to provide, please let me know.


I’m not sure what the underlying issue is, but the location it’s trying to load the scripts from, isn’t where they are.


You can see that it’s trying to load the scripts from the root of the site:

However the cms.js script isn’t at /cms.js but at /admin/cms.js, which you can see here

@Annertech I’ve just spotted that this is occurring when there’s no trailing /

Hey Nathan,

Turns out that the trailing / did the trick. Now it is working (provided that I have re-enabled the git gateway settings thing.

I must confess that I am quite new to netlify, and now that you have figured out can’t help it but feeling a bit silly :frowning:

Thank you very much for your kind and fast response, best regards