AWS DNS intermittent or not working properly

Hi all,

I hope you are well.

I have multiple sites on Netlify, but two are giving me a bit of trouble.

These two sites’ domain names are in AWS. I entered the DNS settings as usual, but they either take too long to propagate, or the green Netlify checkmarks turn from green into yellow warning symbols indicating the DNS is not defined.

Custom domain

Custom domain HTTPS://

I added MX records to connect Microsoft email accounts; however, I’m not sure if it’s conflicting with the DNS information.

I tried adding screenshots, but the system doesn’t let me because I am a new user.

Thank you for your time.

When I run these commands, the information seems to be correct.

dig NS +trace | tail -n 6		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS
;; Received 126 bytes from in 22 ms
whois | grep -i "nserver"

nserver:      A.NIC.ES 2001:67c:21cc:2000:0:0:64:41
nserver:      C.NIC.ES 2001:678:44:0:0:0:0:53
nserver:      G.NIC.ES 2001:500:14:7001:ad:0:0:1
nserver:      H.NIC.ES 2001:678:40:0:0:0:0:53```

Still, it doesn't work.

Any ideas?

Bumping this issue up and hoping to get some help from Netlify support. :slight_smile:

This finally worked.

Steps to reproduce:

  1. Create your DNS records on AWS
  2. Run dig NS +trace | tail -n 6
  3. Ensure all DNS records are from Netlify
  4. Access to monitor DNS propagation
  5. Amazon takes 2 days (48 hours) to complete the process