Auto publish from master branch is not working

my site name is
it used to be auto-deploy from the master branch of my Git but it is not working anymore. for every change I made I have to deploy the site again

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example:
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.


How odd. Usually, for oddities like these, we would suggest that you unlink and relink the Netlify GitHub App. Let me know if this helps! :slight_smile:

Thanks for your help. yes it works now. I had this problem just with one of my app. thanks again

Hey @Pie
I have the same problem with all my projects.
I forced Netlify to make deploy && clear cache. The build is created: ‘Finished processing build request in 50.173954257s’ but nothing more is happening. It used to throw last information ‘your site is live’. I have waited for about 10mins then cancelled deploy and tried a few times. Nothing changes.

Also, I unlink and relink app

EDIT: another person has the same problem: Can't deploy a static site

1 Like

Hey @Albert_Walicki,

Sounds remarkably different to the OP and was, in fact, related to an ongoing issue (

It should now be resolved.

Can you create a new topic and provide us with a deploy log, if the issue persists? Thanks!