Apex domain doesn't redirect to www domain showing ssl error

my site’s www domain (www.kdintelligent.com) work properly but,
apex domain (kdintelligent.com) doesn’t work,
it shows this error:
on chrome

My netlify site name is:
https://focused-poincare-f6670f.netlify.app/

I think there is some problem with the SSL
in firefox, it shows the message in details:

Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for kdintelligent.com. The certificate is only valid for the following names: *.netlify.com, netlify.com

Error code: SSL_ERROR_BAD_CERT_DOMAIN

Hey @iKausik, how long ago did you request the SSL?

Here is my ssl

And this is my DNS records at Namecheap:

Hi, @iKausik, was able to update the SSL certificate by clicking the “Renew certificate” button found here.

This will update the SSL certificate is additional domains are added in the future. This should happen automatically (and it does most of the time). However, if the domain doesn’t get automatically added clicking the button nearly always fixes the issue.

If this button ever doesn’t work, please let us know. We’ll be happy to find out why and get the issue corrected.

1 Like

Thank you luke, I seems to work automatically without doing any further from my side, but if it goes wrong in future I’ll definitely try to renew the certificate. :+1:

1 Like

Hey @luke. I am actually having this same issue with my domain affloorings.com. I am getting a 403 forbidden and I can see my favicon which makes me believe that the apex domain is redirecting to www.affloorings.com but SSL issues seem to be occurring. Please let me know what I can do, thank you.

Edit: I get the exact same warning when I visit affloorings via https://affloorings.com. When I visit the website at http://affloorings.com, I get 403 forbidden. I do not encounter this issue when I visit the website at https://www.affloorings.com.

Edit: I also renewed the SSL certificate recently (September 9th at 2:05am) and that has not done much. Perhaps I may have to wait longer?

Here is a screenshot of my domain management settings.
I also added the A record to point to the netlify IP that is mentioned in the guide on setting up external DNS.

Right now, you’ve got two different sets of configuration, @alex271.

At Netlify, you’ve configured Netlify DNS. Therefore, we’ve created the A/NETLIFY records we need. There appears to be an issue with one of these records which we could work to resolve.

However, if you’re adding an A record at another DNS provider, then you’re not using Netlify DNS. The A record external DNS solution is actually the worst acceptable configuration as you wouldn’t be making use of our CDN.

I’d personally advise that you remove the domain from the custom domains panel, you remove the DNS configuration at your DNS provider and then:

  • Add the domain to your site again
  • Select ‘Set up Netlify DNS’
  • Wait (a very important, undervalued step)
  • If, after 48 hours, things don’t work – reply to this ticket and we can take a look with a clean slate :slight_smile:

Hey @Pie thanks for getting back to me. I removed the domain and set it up again as you instructed. I was told in the set up to add the 4 nameservers to my DNS provider (domain.com) so I only have those 4 nameservers that was provided and nothing else. I removed the A record that I added previously so just the nameservers and the CNAME was kept in my DNS provider.

Do I need to keep one of the domains specifically as a primary domain while waiting for everything to propagate? I previously kept the primary domain as www.affloorings.com. I also should note that I added the HTTPS to the domain as well so I am not sure if that may also be a factor that is contributing to the 403 for my apex domain.

Edit: affloorings.com seems to be working now! Thanks for the help

1 Like