Almost all of my builds are failing suddenly

Since a few days I noticed that more than 50% of my builds are failing due to

5:44:26 PM: Error running command: Command did not finish within the time limit
5:44:26 PM: Failing build: Failed to build site
5:44:27 PM: failed during stage ‘building site’: Command did not finish within the time limit

Until last week I had never seen this issue. My site is a Gatsby site built on top of a headless Drupal source with jsonapi and only has 100-ish content pages with each 1 to 2 images at max.

On my local machine the build time (with .cache and public removed) takes 5-6 minutes, but for some reason on netlify it always takes between 12 and 18 minutes, and now starts timing out.

As a result of all the retries and stuff, I already purchased 4 build minutes packs of 7$ each, but I’m getting pretty desperate to get this fixed.

I tried trimming down image sizes in the backend, minimized the number of images gatsby creates from them etc, but no result. My last attempt was to add the gatsby-plugin-netlify-cache plugin, but no cigar either.

Sitename: kcvvelewijt



hey @soniCaH, that sounds frustrating.

My first thought, since you are dealing with a gatsby build, is to send you this:

It’s providing really great improvements for folks whose builds are timing out because they are taking too long.

If that doesn’t help, let us know - there may be some other things we can try :muscle:

Hey @perry - I followed all steps and my cloud functions are deployed, my pub/sub subscriptions are set-up: all works fine.

But when I try to deploy via netlify, I get authentication/token errors:

5:33:30 PM: error GaxiosError: invalid_grant: Robot is disabled.
5:33:30 PM:     at Gaxios._request (/opt/build/repo/node_modules/gaxios/build/src/gaxios.js:85:23)
5:33:30 PM:     at processTicksAndRejections (internal/process/task_queues.js:97:5)
5:33:30 PM:     at async GoogleToken.requestToken (/opt/build/repo/node_modules/gtoken/build/src/index.js:202:23)
5:33:30 PM:     at async JWT.refreshTokenNoCache (/opt/build/repo/node_modules/google-auth-library/build/src/auth/jwtclient.js:156:23)
5:33:30 PM:     at async JWT.getRequestMetadataAsync (/opt/build/repo/node_modules/google-auth-library/build/src/auth/oauth2client.js:266:17)
5:33:30 PM:     at async JWT.requestAsync (/opt/build/repo/node_modules/google-auth-library/build/src/auth/oauth2client.js:339:23) { 

Googling around seems not to bring any luck. Tried setting the env variable again with my base64 credentials, created a new service account, a new key, nothing works.

Hey @soniCaH,
I started digging into your deploys, but saw that you seem to be publishing again. Are you still running into the issue you posted about?