All pages except home is 404

My package.json:

  "name": "my-remix-app",
  "private": true,
  "sideEffects": false,
  "type": "module",
  "scripts": {
    "build": "remix build",
    "dev": "remix dev",
    "start": "netlify serve",
    "typecheck": "tsc -b"
  "dependencies": {
    "@remix-run/node": "^2.4.1",
    "@remix-run/react": "^2.4.1",
    "cross-env": "^7.0.3",
    "react": "^18.2.0",
    "react-dom": "^18.2.0",
    "@google-cloud/storage": "^7.7.0",
    "@netlify/functions": "^2.0.0",
    "@netlify/remix-adapter": "^2.0.0",
    "@prisma/client": "^5.7.1",
    "@remix-run/css-bundle": "^2.4.0", 
    "bcryptjs": "^2.4.3", 
    "mongodb": "^6.3.0"
  "devDependencies": {
    "@remix-run/dev": "^2.4.1",
    "@remix-run/eslint-config": "^2.4.1",
    "@remix-run/serve": "^2.4.1",
    "@types/react": "^18.2.0",
    "@types/react-dom": "^18.2.0",
    "eslint": "^8.27.0",
    "typescript": "^5.2.2", 
    "@remix-run/v1-route-convention": "^0.1.4"
  "engines": {
    "node": ">=18"

I think it’s not about prisma, because home page works fine.
I used this steps: Remix on Netlify | Netlify Docs and just added prisma file and updated package.json

Also, I added to netlify.toml but it don’t affected:

from = "/*"
to = "/index.html"
status = 200

Can someone help me to understand why I have 404 plaese?

Hi there,

Thanks for reaching out! I’m reviewing this site now, and I’m actually seeing a 404 being thrown for the home page as well.

Are you able to properly serve the site files locally? If so, I’d also recommend confirming that the path to the directory where the site files are published (should be public for Remix) matches the Publish Directory that you have configured in the site settings.

If this matches as well, I’d be curious as to whether these 404s were present before the inclusion of the Prisma file - a quick test of the Remix template you linked above confirms that the files should be deployed properly with the repo as is, so this should help to continue narrowing down what the issue might be. Thanks again!