"404 Not found" error when using createSiteInTeam endpoint


Our team creates sites on Netlify using the createSiteInTeam endpoint via the NodeJS client.

It has worked fine for us up until 03/31. Specifically, our logs show that the last successful response we received was at 2022-03-31T12:45:24.408-04:00 for the site Netlify App

Starting at 2022-03-31T13:09:45.552-04:00, we started seeing that endpoint respond with the error response:

“code”: 404,
“message”: “Not Found”

All subsequent requests got the same error. We have not had a successful response since.

Could someone take a look? Please let me know if you need more information.

Hey there, @chan.lee :wave:

Thanks for reaching out about this! I just wanted to close the communication loop and confirm that members of the Support team are assisting you in the helpdesk. If you have further information and questions, please follow up with them via email!


1 Like

For anyone else who stumbles across this, this happened because the access token we were using expired.

Hopefully this won’t be a problem going forward as the support team filed a bug to have these kinds of issues respond with a more appropriate response code.

Thanks so much for coming back and sharing this, @chan.lee! This will definitely be beneficial for future Forums members who encounter something similar.