When my gatsby site is deployed to netlify netlify uses the wrong version olf Node.js

Today I tried to deploy my gatsby site which has been updated to 3.2.1, and Netlify ended up using the wrong version of Node. I use 14.4.0 on my computer, and it was using 10. Why is that? I haven’t used 10 in like forever! And gatsby 3.2.1 needs at LEAST version 12 or greater. What is going on?

How can I get this resolved? Otherwise I will have to find another hosting provider and maybe even not use Gatsbyjs any more if it is going to cause so many headaches. So much for speedy deployment, huh? And I pay for this service.

No one is using Node.js 10 anymore. If I keep on getting this, I won’t want to use Netlify anymore! This is ridiculous. How can I get rid of that cache???

The better the post - the faster the answer.

hi there, welcome! you can set the node version you need - here are some instructions from our docs on how to do so:

Thanks. That worked. Unfortunately then an underlying problem surfaced as a result. There is a conflict between the version of gatsby I am using and netlify-cms. And I believe that there is no resolution at this time. Something related to sass used under the hood in Gatsby is conflicting with netlify-cms and causes my build to crash on deployment. Locally the build is successful. Unfortunately I don’t even have the time to figure it out and fix it.

I finally got everything up and running just a little while ago. First of all, I found out that Gatsby and pure npm don’t play nicely together anymore. That was a large part of the problem. Then I found that the CSS Modules as I had used them in my site is not recognized by Gatsby 3.0+ and was breaking my build. So I had to fix that. It even disabled my non Gatsby JavaScript. But everything now is working as before. Im not even done with tinier details, but that can wait for another day. This did not come at a good time, but boy did I learn a lot! Thanks for your help here.

1 Like

you are welcome, @interglobalmedia ! Come back any time if you need more help with things. And thanks for sharing what you learn - it helps others in the same situation!

Just an update Perry. Everything is working beautifully. I’m writing a post about the issues I encountered and what was causing them. I include the .nvmrc step as well. So good to know, And was easy for me since I use nvm anyway! Thanks again so much for your help! I will share here in case if it can help others, because I have seen many issues posted on Github and related posts elsewhere that don’t get to the crux of the matter. Simply temporary workarounds. In many cases, those workarounds can be avoided!