Website won't build when using .nvmrc file

3:33:14 PM: build-image version: 3d3c7e8b4321e2c1a54a2c4584fb46ba742b1630 (focal)
3:33:14 PM: buildbot version: 3b67b7d618a27c5b3d9a768872060db0ddff3d98
3:33:14 PM: Fetching cached dependencies
3:33:14 PM: Starting to download cache of 302.6MB
3:33:16 PM: Finished downloading cache in 2.005s
3:33:16 PM: Starting to extract cache
3:33:19 PM: Finished extracting cache in 2.876s
3:33:19 PM: Finished fetching cache in 4.932s
3:33:19 PM: Starting to prepare the repo for build
3:33:19 PM: Preparing Git Reference pull/4/head
3:33:21 PM: Starting to install dependencies
3:33:22 PM: Python version set to 3.8
3:33:22 PM: Attempting Ruby version 2.7.2, read from environment
3:33:22 PM: Using Ruby version 2.7.2
3:33:23 PM: Started restoring cached go cache
3:33:23 PM: Finished restoring cached go cache
3:33:24 PM: go version go1.19.13 linux/amd64
3:33:25 PM: Using PHP version 8.0
3:33:26 PM: Started restoring cached Node.js version
3:33:28 PM: Failed during stage 'Install dependencies': dependency_installation script returned non-zero exit code: 1
3:33:28 PM: Finished restoring cached Node.js version
3:33:28 PM: Attempting Node.js version '20
' from .nvmrc
3:33:28 PM: Version '20
' not found - try `nvm ls-remote` to browse available versions.
3:33:28 PM: Failed to install Node.js version '20
'
3:33:28 PM: Failing build: Failed to install dependencies

I have tried various ways of listing the node version in the file and they all have the same results. When I try building to version 20.14.0 on a branch that doesn’t have the nvmrc file the project builds just fine. I have reason for needing to include the nvmrc file in the GitHub repo, is there any way to fix this issue or just have Netlify ignore that file all together?

I found the solution to the issue. The issue came from the file using CRLF line endings I changed it to LF line ending in my text editor, afterwards the builds started succeeding again.