Unable to update an Integration

I’m using the Cloudinary integration and have noticed it’s loading an older version of the plugin. I know this because I use a configuration option that gives a build error, and in the build error, the version reported is way behind the most recent version.

The UI doesn’t give any option to update the integration. I even tried removing it in the UI and just specifying it in my netlify.toml file, but it refuses to load the most recent version.

What can I do?

Mind sharing the site name?


did you add it to your package.json?

Nope. Is that required? If so, it doesn’t seem to be documented. And why wouldn’t adding via the UI get the latest?

This is documented: Build Plugins | Netlify Docs.

The plugins in the UI come from: netlify/plugins: Netlify plugins directory. (github.com), so if a version is not updated there, the UI won’t have the latest update.

So I’m confused. On npm, the latest version is 1.15.0. If I don’t specify a version in package.json, but just ask for it in netlify.toml (and the UI), why isn’t that version loaded?

hey :wave: im the author of this plugin

This is documented: Build Plugins | Netlify Docs .

specifying the package as an npm dependency does not work, have mentioned it to team members via our connected slack before and haven’t heard back yet about the issue

The version is up to date in npm and this was previously working, however there must have been a change that is now preventing the version change. Updating those versions is not something I can control, but npm has 1.15.0 available: netlify-plugin-cloudinary - npm

@colbyfayock, you’re saying specifying the plugin’s version in package.json is not working? That would break a lot of sites on Netlify right now. Do you have an example project?

in devDependencies as documented. I tried on other projects as well. It was never able to change the version from the currently offered Netlify UI version

regardless - this is a separate issue. Changing the Version in the UI was previously working and has since disappeared. it’s both pointing to an old version and unable to change the versions

and one point of clarification is currently the use of ^ which i believe would opt into minor updates (making it currently appear working), but previous when publishing new versions before Netlify updated the Netlify-available version, it would not opt into that new version

I’ve already mentioned why. Your plugin is pinned to an older version there: plugins/site/plugins.json at main · netlify/plugins (github.com)

With the move to integrations hub, we’ve kinda moved away from relying on UI for build plugins. The above mentioned repo is only active for some internal plugins, but I don’t think it’s actively getting any other traffic. As you can see, the PRs are mostly all just internal ones: Pull requests · netlify/plugins (github.com).

This, I am not sure about and we can’t go back in time to confirm. But using package.json to specify the version of plugin you need to use has been a standard for quite a few months now.

So wait - is it fair to say Netlify will use the default at their repo, which you say is not being used anymore (or much), when it comes to picking a version, and therefore, developers should specify a version in their package.json? If so, that is not clear in the docs. I mean yes, the docs show how a person could specify the version, but not that they would have to, as I think most would assume (I know I did), that the most recent version wouldbe used.

For what it’s worth, based on @colbyfayock’s reaching out to the partners team, it’s being investigated as to why the plugins in the repo did not sync with some other changes we had made to get the plugins updated. Once that’s fixed, I believe the latest version should be available in the repo and thus, in the UI.

1 Like