Unable to get updates when deploying my website

Hi there,

I’m using Netlify to deploy my website. However, the changes made on the GitHubb repo are not being put through. Could you please advise?

The url in question is https://ata-uk.org and the GitHub repo is GitHub - AshNaz87/afghanistan-turks-association.

Thank you.



@AshNaz87 Welcome to the Netlify community.

Are you certain that your Netlify site is connected to the correct Github repository?

What happens when you click the button to request a manual deploy?

Hi @gregraven,

Thanks for replying.

I’m pretty sure. In “Build Settings” the repository shown is https://github.com/AshNaz87/afghanistan-turks-association, which is the correct repo.

I’ll keep digging though…

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Still not having any luck.

Below is my package.json

  "name": "@ashnaz87/afghanistan-turks-association",
  "description": "Repository for Afghanistan Turks Association UK website",
  "version": "1.0.0",
  "author": "AshNaz87 <ashraf.caspian@gmail.com>",
  "license": "MIT",
  "repository": {
    "type": "git",
    "url": "https://github.com/AshNaz87/afghanistan-turks-association.git"
  "bugs": {
    "url": "https://github.com/AshNaz87/afghanistan-turks-association/issues"
  "scripts": {
    "build": "GATSBY_EXPERIMENTAL_PAGE_BUILD_ON_DATA_CHANGES=true gatsby build --log-pages",
    "develop": "gatsby develop",
    "format": "prettier --write \"**/*.{js,jsx,json,md}\"",
    "start": "npm run develop",
    "serve": "gatsby serve",
    "clean": "gatsby clean",
    "test": "echo \"Write tests! -> https://gatsby.dev/unit-testing\" && exit 1"
  "dependencies": {
    "bootstrap-scss": "^4.5.3",
    "gatsby": "^2.27.4",
    "gatsby-background-image": "^1.1.1",
    "gatsby-image": "^2.4.3",
    "gatsby-plugin-advanced-sitemap": "^1.5.4",
    "gatsby-plugin-google-analytics": "^2.3.2",
    "gatsby-plugin-manifest": "^2.4.3",
    "gatsby-plugin-netlify-cms": "^4.3.2",
    "gatsby-plugin-netlify-cms-paths": "^1.3.0",
    "gatsby-plugin-offline": "^3.2.2",
    "gatsby-plugin-react-helmet": "^3.3.1",
    "gatsby-plugin-sass": "^2.3.1",
    "gatsby-plugin-sharp": "^2.9.1",
    "gatsby-remark-images": "^3.3.3",
    "gatsby-remark-prismjs": "^3.5.1",
    "gatsby-remark-reading-time": "^1.1.0",
    "gatsby-remark-responsive-iframe": "^2.4.2",
    "gatsby-source-filesystem": "^2.6.1",
    "gatsby-transformer-remark": "^2.11.1",
    "gatsby-transformer-sharp": "^2.5.2",
    "netlify-cms-app": "^2.14.1",
    "node-sass": "^4.14.1",
    "prismjs": "^1.20.0",
    "react": "^16.12.0",
    "react-dom": "^16.12.0",
    "react-helmet": "^6.0.0",
    "react-icons": "^3.10.0"
  "devDependencies": {
    "acorn": "^6.4.1",
    "netlify-cms-lib-widgets": "^1.3.0",
    "prettier": "2.0.5",
    "react-refresh": "^0.8.2",
    "redux": "^3.0.0",
    "typescript": "^3.9.2"

When running gatsby info I get:

    OS: macOS 10.15.7
    CPU: (8) x64 Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
    Shell: 5.7.1 - /bin/zsh
    Node: 12.18.3 - ~/.nvm/versions/node/v12.18.3/bin/node
    Yarn: 1.22.5 - ~/.yarn/bin/yarn
    npm: 6.8.0 - ~/.node_modules_global/bin/npm
    Python: 2.7.16 - /usr/bin/python
    Chrome: 87.0.4280.67
    Firefox: 83.0
    Safari: 14.0.1
    gatsby: ^2.27.4 => 2.27.5 
    gatsby-background-image: ^1.1.1 => 1.3.1 
    gatsby-image: ^2.4.3 => 2.6.0 
    gatsby-plugin-advanced-sitemap: ^1.5.4 => 1.5.6 
    gatsby-plugin-google-analytics: ^2.3.2 => 2.6.0 
    gatsby-plugin-manifest: ^2.4.3 => 2.7.0 
    gatsby-plugin-netlify-cms: ^4.3.2 => 4.5.0 
    gatsby-plugin-netlify-cms-paths: ^1.3.0 => 1.3.0 
    gatsby-plugin-offline: ^3.2.2 => 3.5.0 
    gatsby-plugin-react-helmet: ^3.3.1 => 3.5.0 
    gatsby-plugin-sass: ^2.3.1 => 2.6.0 
    gatsby-plugin-sharp: ^2.9.1 => 2.9.1 
    gatsby-remark-images: ^3.3.3 => 3.6.0 
    gatsby-remark-prismjs: ^3.5.1 => 3.8.0 
    gatsby-remark-reading-time: ^1.1.0 => 1.1.0 
    gatsby-remark-responsive-iframe: ^2.4.2 => 2.6.0 
    gatsby-source-filesystem: ^2.6.1 => 2.6.1 
    gatsby-transformer-remark: ^2.11.1 => 2.11.1 
    gatsby-transformer-sharp: ^2.5.2 => 2.7.0 
    gatsby-cli: 2.14.1

From the deploy logs:

11:37:13 PM: success write out redirect data - 0.001s
11:37:13 PM: vips_value_hash: no case for NULL
11:37:13 PM: 	type 64, gchararray
11:37:13 PM: 	generic 53, GParamString
11:37:13 PM: vips_value_hash: no case for 0.000000
11:37:13 PM: 	type 60, gdouble
11:37:13 PM: 	generic 109, GParamDouble
11:37:13 PM: vips_value_hash: no case for FALSE
11:37:13 PM: 	type 20, gboolean
11:37:13 PM: 	generic 76, GParamBoolean
11:37:13 PM: vips_value_hash: no case for ((VipsAccess) VIPS_ACCESS_RANDOM)
11:37:13 PM: 	type 71654592, VipsAccess
11:37:13 PM: 	generic 80, GParamEnum
11:37:13 PM: vips_value_hash: no case for FALSE
11:37:13 PM: 	type 20, gboolean
11:37:13 PM: 	generic 76, GParamBoolean
11:37:14 PM: ​
11:37:14 PM: ────────────────────────────────────────────────────────────────
11:37:14 PM:   "build.command" failed                                        
11:37:14 PM: ────────────────────────────────────────────────────────────────
11:37:14 PM: ​
11:37:14 PM:   Error message
11:37:14 PM:   Command was killed with SIGSEGV (Segmentation fault): gatsby build
11:37:14 PM: ​
11:37:14 PM:   Error location
11:37:14 PM:   In build.command from netlify.toml:
11:37:14 PM:   gatsby build
11:37:14 PM: ​
11:37:14 PM:   Resolved config
11:37:14 PM:   build:
11:37:14 PM:     command: gatsby build
11:37:14 PM:     commandOrigin: config
11:37:14 PM:     environment:
11:37:14 PM:       - NODE_VERSION
11:37:14 PM:     publish: /opt/build/repo/public
11:37:14 PM:   plugins:
11:37:14 PM:     - inputs: {}
11:37:14 PM:       origin: config
11:37:14 PM:       package: netlify-plugin-gatsby-cache

Lastly, my Build Settings screenshot is attached

Any assistance would be greatly appreciated.

@AshNaz87 Maybe we should start with the basics. What is your custom domain name? The one you have in your original post links to a site that appears to have nothing to do with your content. Also, what is your Netlify subdomain?


My default subdomain is https://afghan-turks-org.netlify.app

Don’t think I have a custom domain name

I originally forked a repo as a template for my Gatsby website. Hence the different content

Also, my netlify.toml is:

  publish = "public"
  command = "gatsby build"


  package = "netlify-plugin-gatsby-cache"

@AshNaz87 Ah, the default content was throwing me for a loop, but of course the reason it is there is because your personal content isn’t making it through the build process.

I’m afraid I don’t use Gatsby, so I can’t be as much help as others might. Have you checked this post?

Finally, this might not be a problem with Netlify. It seems you were able to build the default Gatsby instance successfully. The fact that it will not update indicates that you made some edit that upset the build process. If I were in your position, I would download another instance of that same Gatsby template into a separate project, then do a folder comparison to see what has changed in the key files that define the build settings.

Hi @gregraven

I managed to get in contact with the maintainers of the original repo. They suggested that I revert the netlify.toml file to its original state. I did do that and pushed, but was still seeing the build failure message.

However, when using the Netlify CLI, when I performed

netlify build && netlify deploy

it worked. Really strange that. I believe others have reported something similar. Would be great if you could shed some light on this.

1 Like

@AshNaz87 I just visited your site and saw new content, so it seems you are getting closer.


Yeah that was following the use of Netlify’s CLI. Scratching my head on this one

hey @AshNaz87, sorry to be slow to reply to you!

We’ve talked about this interally and are thinking that this might be a plugin issue.

To rule that out, can you get a build to complete properly without the plugin?

this might also be helpful:

Hi @perry

Which plugin are you referring to?

:this: one was my thinking

@perry No luck, I’m afraid

I get these error messages

error Unexpected key "componentDataDependencies" found in preloadedState argument passed to createStore. Expected to find one of the known reducer keys instead: "nodes", "logs", "pages", "redirects", "schema", "definitions", "staticQueryComponents", "status", "webpack", "pageData", "themes", "webpackCompilationHash", "config", "lastAction", "jobsV2", "pageDataStats", "components", "babelrc", "jobs", "nodesByType", "program", "resolvedNodesCache", "nodesTouched", "flattenedPlugins", "pendingPageDataWrites", "schemaCustomization", "inferenceMetadata", "staticQueriesByTemplate", "queries", "visitedPages". Unexpected keys will be ignored.


Error message Command failed with exit code 139: npm run build Error location In build.command from netlify.toml: npm run build

I wonder too if this pertains to running gatsby-plugin-offline since running a local service worker can often make it appear as though a site’s content hasn’t changed at all.


Hi @jonsully

Tried that too. No joy.

I do suspect it is a dependency though. Will post an update if ever I do find out what the cause is

1 Like

Hey there,
Not sure if you’ve resolved this since writing in, but wanted to share this thread that suggests that the error is related to the vips dependency: https://github.com/gatsbyjs/gatsby-source-wordpress-experimental/issues/348