Unable to checkout repo due to LFS issues

Unable to check out repo. Followed this guide but nothing in there helps. I don’t even mind if the files are deleted and I can re upload them again - just need to be unblocked from checking out or pushing changes from my already checked out branch.

Site URL: my full name.com (I can’t post more than 6 links because I am new to the forum)
Netlify account email: hello [at] vinayraghu.com

Issue: Keeps asking for login but fails. My .gitignore does not ignore my large files.

time=“2021-02-04T12:25:23-05:00” level=error msg=“Aborting Netlify credential helper execution” error="&{0 } (*models.Error) is not supported by the TextConsumer, can be resolved by supporting TextUnmarshaler interface"
Username for ‘https://3564fb20-4b15-4cc0-a5bf-46a0d0f95d42.netlify.app’:

My LFS config (I tried both .com and .app)
[lfs]
url = https://3564fb20-4b15-4cc0-a5bf-46a0d0f95d42.netlify.app/.netlify/large-media

git version
git version 2.19.2

git lfs version
git-lfs/2.7.1 (GitHub; darwin amd64; go 1.12)

netlify lm:info
:heavy_check_mark: Checking Git version [2.19.2]
:heavy_check_mark: Checking Git LFS version [2.7.1]
:heavy_check_mark: Checking Git LFS filters
:heavy_check_mark: Checking Netlify’s Git Credentials version [0.1.9]

Please can you help point out what I could be doing differently?

Hi, @vinayraghu . I believe you are running into this issue:

https://github.com/netlify/cli/issues/514

The workaround reported to have worked for some people is to use the auth token from the web UI:

https://docs.netlify.com/cli/get-started/#obtain-a-token-in-the-netlify-ui

If using that auth token doesn’t work, the only other solution currently is to stop using Large Media. If you want us to do so, please read this support guide first and let us know when you are ready for us to proceed:

If there are questions, please let us know and we will be happy to answer.

@luke Thanks for the prompt reply and the links. Unfortunately, the workaround did not work for me so we will need to proceed with uninstalling large media on my site.

I have backups of the files so no worries regarding that. However, I do have a couple concerns:

  • Is this the end of the road for me to use Large media or can I add it back on (maybe make a new repo or something)?
  • I am concerned that at my current state I am not able to reset my branch, checkout a new branch or push from my branch. I am worried if I can’t push to the repo even after you have removed large media.

In any case, I think it’s prudent to proceed and get it removed. So please do the needful and let me know. I appreciate your help. Here’s a shoutout to your team :slight_smile: https://twitter.com/vinayraghu/status/1357663324897435648

Hi, @vinayraghu. We have removed the Large Media add-on from this site.

Would you please push the commit removing .lfsconfig to the upstream repository? This will trigger a new build.

Please let us know if there are any issues with the new build or deployed site.

@luke I think that solved it. Thank you very much :pray: