Tailwind style doesn't render completely

hi i’m working on my portfolio which is built upon next.js, the problem is tailwind codes work on local space but when it comes to netlify they don’t , here is the link to my project : https://celadon-douhua-b653f7.netlify.app/

>> postcss.config.mjs

/** @type {import('postcss-load-config').Config} */
const config = {
  plugins: [

export default config;

>> tailwind.config.js

/** @type {import('tailwindcss').Config} */
module.exports = {
  content: [
  theme: {
    extend: {
      backgroundImage: {
        "gradient-radial": "radial-gradient(var(--tw-gradient-stops))",
          "conic-gradient(from 180deg at 50% 50%, var(--tw-gradient-stops))",
  plugins: [
    function ({ addVariant }) {
      addVariant('child', '& > *'); // Targets direct children
      addVariant('child-hover', '& > *:hover'); // Targets direct children on hover

What doesn’t work exactly?

Looked at the console? There are several errors logged.

wow, why don’t i see these error ? tried both firefox and chrome, don’t know what’s wrong with it , any way as you might have seen some code that i have written with tailwind doesn’t work, only pure css codes are applied ( because i have used both pure css and tailwind )

it’s so nonsense because i have tested on local and everything seems fine.

here is a pic

Like so many things in the world.

With a production build?

i’ve tried building it as static files, didn’t work, here is my repo if you want to check it out, i’ve been looking at my so called masterpiece for 5 hours straight haha, some help would be really appreciated,

github repo : https://github.com/MRGando/Portfolio.git

Not nonsense after all :wink:


Doesn’t look like a Netlify issue. Running npm run build && npm run start locally shows the same issue.