[Support Guide] I’ve deployed my site but I still see "Page not found”

Umm so I don’t know why I’m getting this error, my site got deployed and it even loads but if I try to load it by the routes then it shows me that “page not found” error.
For example these are some of the routes my site has

  1. https://linksforyou.netlify.app/ (main route)
  2. https://linksforyou.netlify.app/months
  3. https://linksforyou.netlify.app/months/January

All 3 routes work perfectly but only if I go to the “1” route before
If I go to 2 or 3 first then I get “Page Not Found”

Github repo link
https://github.com/zarc1411/LinksForYou-frontend

My build settings
https://files.catbox.moe/ndei97.png

ETA
My issue got solved!

Hello,
My site is showing page not found error even though an index.html file.

https://ecstatic-shirley-62bf6c.netlify.app/

@shubhitiwari426 Welcome to the Netlify community.

Please double-check your deploy to make certain that your index.html file is at the top level.

Hi, I’m new here.

Just did my first successful deploy from Hugo-generated site.

When I attempted to pull up my site from my domain name kulbe.dev, I get a 404.

When I attempt to pull it up from the Netlify name kulbedotdev.netlify.app, it comes up, but there’s no theming to it.

When I pull it up by the domain name, from my phone (but here’s the kicker… with wifi off), it comes up properly, theme and all.

Actually, now that I’m on a different machine and it works… I think it may be something environmental. Sorry!

Hi, @akulbe. It does work when I test as well.

TTL values (time to live values) in the previous, not the new, DNS records are often the root cause for delays in changes to DNS. There is more about this behavior (which true for all DNS - not just sites or DNS at Netlify) here:

If there are other questions about this, please let us know.

Hi,

I am also having a similar problem of not being able to publish my website on github.
I deployed the code and in my page, it says the site is published. I also downloaded my deploy log and the root file contains index.html. But I still cannot access the domain of my website ~github.io/. Could anyone please help me in solving this issue?

Thanks in advance.

@jooy Welcome to the Netlify community.

Please help us help you by writing a good post!

All issues: Provide your Netlify site name (e.g. gifted-antelope-58b104.netlify.app).

DNS or SSL issues: Tell us your custom domain(s) (e.g. mycustomdomain.com), and how long it has been since you made changes to your DNS (DNS changes can take up to 48 hours). We can’t help if we don’t know your domain.

Build issues: Tell us about your workflow, including what SSG you are using.

If you are deploying via git, give us the URL of the repository.

Let us know what you have already tried and what the results were.

The better the post = the faster we can help!

Hi!

My Netlify site name is gallant-haibt-7c9b31.netlify.app
And my git repository URl is (https://github.com/juliajoo/juliajoo.github.io).

@jooy Your site seems to be loading for me. Are you certain this isn’t a local issue, perhaps with your browser cache, VPN, etc?

Hi.

I don’t think so, because if I also run juliajoo.github.io on safari browser, it still shows me this 404 error message.

@jooy Sorry, but I don’t have the patience to troubleshoot an issue with Github Pages. There are many reasons why I use Netlify instead of Github Pages. If your site is loading on Netlify, I recommend turning off Github Pages for this site, which solves this problem.

Thank you for the advice. I unpublished the github pages for the repository, redeployed it via Netlify but somehow I still see the same URL ~github.io on my main site overview page. And still it shows 404 error. Do you have any idea how I can fix this problem?

hey @jooy, i’m not sure i’m following. can you please try and explain in a different way what you are trying to do?

you won’t be able to serve a netlify page by pointing your browser to a github pages address (or vice versa.)

@jooy You’ve made another change, too, because now your site isn’t loading.

What are the steps someone else can take to try to reproduce this?

Hi Perry,

ye I went through other sources and realized that it won’t work as far as the webpage is in the gh-page repository as mentioned here: https://www.aleksandrhovhannisyan.com/blog/github-pages-vs-netlify/

I quite didn’t know how to move it to other repository, so I just deleted the current one and reforked it. And didn’t made it into gh-page but instead linked the repo right away with netlify. Now it works! thanks!

Hi Greg,

sorry for the confusion! I didn’t realize the old link was still here in the community. Even after I unpublished the repo, it kept linking me to ~github.io, so I just deleted the repo, reforked it, made new repository and linked it right away to netlify without creating a gh-page. And now it works, thanks for your advice pointing out the gh-page & netlify crashing!

But if I git pull and push changed code to the github repo (which is not gh-page but directly linked to netlify), would the changes well updated on to the published webpage?

Hi,
I am trying to deploy my site to laughing-haibt-2bc0ac.netlify.app
Deploy is “Published” (like on the screen from OP)
The site is built using a single HTML-file from my Github (50MB of size, isn’t it a problem?)
However, I still see “Page not found”

@lifegivesyoulemons Welcome to the Netlify community.

Your page is loading, but there’s something wrong with your code because it’s not showing anything. It’s also taking forever, which may or may not be related.

WARNING: This file appears to be toxic. I’ve tried opening it in three different text editors and it crashed each of them. My text editors virtually never crash. Be very careful examining the source code of this site.

i didn’t try opening it like gregraven did, but i also see a blank page (not page not found).

@lifegivesyoulemons, does this run locally? a 50MB file is a bad idea on our servers anyway - they are really optimized to serve the small assets generally used by static sites.