[Support Guide] How can I receive emails on my domain?

I’m trying to apply the suggestions in the first post with my hosting but I still can’t receive any email.

My hosting’s guide suggests (translated):
If you use smtps.aruba.it , pop3s.aruba.it and imaps.aruba.it they can be set with only record MX and linked record A :

A  **only**  Record MX:
Name record MX:  **DOMINIO**  of type  **MX**  with priority:  **10**  heading on **mx.DOMINIO**
(on some provider MX field can be left the  empty)

mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:
mx  *type_record:*  A IP:

Non sono quindi necessari i restanti record.

Any suggestion please?

My hosting provider told me to contact Netlify to manage the emailbox since I changed DNS…:confused:

Could you tell us what domain you use, please, so we can examine your current settings and get you the best advice? Thanks in advance for your help in troubleshooting!

It says us to register a different domain.
I have registered zoho mail for my netlify subdomain and that add or register domain or any dns records does not accept my current subdomain address.So th above screenshot is valid but what to enter before that in add or register domain?

I have a domain from mailchimp and they don’t have a cpanel or an email service

I’m not too sure how thing’s work over at Mailchimp but the easiest thing to do would be to point your domain to Netlify’s DNS at your registrar (Mailchimp). Then, you can follow the guide for adding your mail service to Netlify using our DNS.

Hi there,

Apologies for a simple question, I’m new to this.

I am using a new droplet on DigitalOcean with Mail-in-a-box setup. What do I put as the value when creating the MX record?


Hi, @kunalnagar, this looks like a wonderful service and I wish knew the answer, but I’ve never used it before and won’t have time to research it (much).

Our scope of support for our support team is limited to Netlify itself (but someone else here may answer this). This is a questions about Mail-in-a-box and not Netlify.

I think the instructions to find the required DNS records are found here.

However, those instructions are something only you can do (because we don’t have access to your droplet). We need you to tell us what the correct DNS records are and then we can answer any questions about getting the records working with Netlify DNS.

To summarize, we can help you troubleshoot Netlify DNS but not Mail-in-a-box itself. Once you know the correct Mail-in-a-box settings we can help if there are questions about creating the required records with our service.

If there are other questions about this, please let us know and we’ll do our best to answer (inside the scope of our support).

Hi Luke,

Thanks for the reply. It was actually a no-brainer. All the settings were in the Mail-In-A-Box Admin Panel under a menu option :slight_smile:

The only other thing that I am looking for is DNSSEC, but I guess I can follow this thread for that. Thanks again!

Hi, @kunalnagar. Thank you for sharing where to find the required DNS settings for Mail-In-A-Box. Hopefully this will be helpful others using Mail-In-A-Box or running their own mail servers.

I’m also glad to learn that you were able to get the DNS configuration working. I had not heard of Mail-In-A-Box before and I’m personally also quite interested now.

Yes, the DNSSEC is still an open feature request and that thread will be updated if/when this becomes available with Netlify DNS.

If you have other questions about this or want to share any tips you think might help others using Netlify DNS and Mail-in-a-box together, please feel free to follow-up here or even make a new topic to discuss. :+1:

Hi @luke. It is by far the simplest out-of-the-box solution that I’ve found for configuring a custom email server from scratch. Plus, it comes with NextCloud and Let’s Encrypt which means you have your own little cloud running with little to no-effort. There are some things that may need customization and I’m planning to do a blog post on it soon.

For example, my domain is with Google domains. My website for that domain is hosted on GitHub pages (I had to move from Netlify because of DNSSEC but I’ll be back). And my email + NextCloud is hosted on a DigitalOcean droplet. That’s a lot of moving pieces and I’m sure a blog post could definitely help someone pick and choose what they want.

If you or anyone has any questions for now, please feel free to reach out at: knlnagar[at]gmail[dot]com

Thanks again for taking the time to reply back. Have a great day and stay safe! :slight_smile:

Where do I check if email is working after I add an MX record to my Netlify domain panel?

Hi, @68mph. You can send an email to that email address to see if it is delivered.

Also, the email service provider might have some tools to confirm the DNS configuration. That varies by email service provider though.

In other words, to test the email service please consult the email service provider for instructions about how to do so.

For the MX record itself, you can make DNS queries to test it. Google provides a free web based tool to do DNS lookups here:

If there are other questions about this, please let us know.

Hi there,
I am trying to set up gmail for the domain I just purchased on netlify. I am attempting to follow the step by step provided here and having some difficulty. Apologies.

I don’t see a blue Netlify DNS label to access the DNS panel. Also when I try to progress on the google side, I get this message “We’ve detected that your domain host is NS1. Sign in to add verification codes to your domain settings.”

I have learned that NS1 is your third-party DNS provider. However when google work prompts me to log into NS1, I don’t have a log in credential since I purchased the domain through you. Do I just go ahead and create an NS1 account and proceed from there?

Any help and clarity would be much appreciated. Thanks!

1 Like

Hi, @threeqube. Google is right about the DNS service at NS1 but they are incorrect about you having access to the NS1 account.

You wrote:

I don’t see a blue Netlify DNS label to access the DNS panel.

It does say “click the blue NETLIFY DNS label” above but that is only found in the site settings page. You can also get to the page to add the record via Account Name > Domains > “Name of the domain”.

(Note, I’m also about to edit the support guide above to clarify this so it will likely be changed by the time you read this.)

Now, I’m guessing that Google has some option or feature which works like this:

  • Just login to NS1 here via our Google site to give us access and we will automatically create these DNS records for you.

If so, it isn’t currently possible for you to use that feature (because, as you stated before, you don’t have direct access to the NS1 account). Because of this, I would recommend you just make the records at Netlify manually yourself.

There should be a way in the Google web app to get the required DNS records. Then you personally enter those records by hand at Netlify in the Netlify DNS settings page.

If there are any questions about how to create records at Netlify, please let us know what records are required and we will be happy to answer any questions about how to create them.

I have somewhat the same issue as threeqube:

I use the Netlify DNS. In order to use GSuite (now ‘Google Workspaces’) for email, Google wants me to first verify ownership of the domain by adding a TXT record with a verification code.

Google autodetects the domain host as NS1. I assume that I can simply create the TXT record in my Netlify DNS.

However, I did this last week and the domain still has not been verified by google. I’ve tried using a CNAME record for verification instead, but still no joy - it just keeps telling me that I need to verfify the domain.

So: The verification TXT record I set up in Netlify DNS, is that not automatically propagated to NS1?

Hi, @ulyngs. The record should be a TXT type record. I only see one of those on the domains configured for your team and it works when I test:

$ dig +noall +answer <domain redacted> TXT
<domain redacted>.	3599	IN	TXT	"google-site-verification=Ksy7o3hgE7q77-aW4mfHf5ZpPlVIlglSSkPV_i2zoL4"

I’m happy to openly discuss the actual domain name if you share it or give me permission to do so. Again, the only verification record I can see is working when I test it. If there is some other record not working, please let us know what it is and we will be happy to assist.

Thanks for looking into this, Luke!

Sure thing, I think there’s nothing that needs to be secret:

I bought the domain redd-project.org through Google Domains, then used Netlify’s DNS to make it the custom domain for redd-workshop.netlify.app.

I want to be able to email from someusername@redd-project.org and would like to use Google Workspace, as the domain is already registered through Google Domains.

  1. Google prompts me to verify that I own redd-project.org (even though I actually bought it through Google - I think this would be automatically verified if I hadn’t moved the DNS to Netlify).

  2. they prompt me to do so by adding a TXT record

  3. and they provide these steps for doing so which I’ve followed

But the verification never goes through. Any suggestions as to why that might be?

(The workaround I thought of is to move the DNS back to google’s name servers, then register with google workspace (the domain verification should now be straightforward), then afterwards move back to netlify’s DNS again)

HI, @ulyngs. Personally, I cannot explain it. The record works when I test. I’m just as confused as you are.

I’m showing the record is working:

$ dig redd-project.org txt

; <<>> DiG 9.10.6 <<>> redd-project.org txt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41241
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;redd-project.org.		IN	TXT

redd-project.org.	3599	IN	TXT	"google-site-verification=Ksy7o3hgE7q77-aW4mfHf5ZpPlVIlglSSkPV_i2zoL4"

;; Query time: 73 msec
;; WHEN: Thu Mar 04 00:39:22 PST 2021
;; MSG SIZE  rcvd: 126

The same is shown with Google’s dig tool:


So, I cannot think of any reason why it wouldn’t work. Do they want you to perhaps use some subdomain and not the apex domain like something-here.redd-project.org? (I think they always use the apex though.) Could there be a typo in the key itself?

The WHOIS record also shows the domain settings were recently changed (Updated Date: 2021-03-03T07:47:20Z). It could be that the TTL for the previous NS records hasn’t expired:

If so, it might help to purge their DNS caches here:

Note, I did just flush the NS records for redd-project.org there and it could be that this is all that was required (but only testing would confirm so I don’t know if that is true or not).

If it still doesn’t work or if there are other questions, please let us know.