"Successful" build with hugo, but pages missing

Hello,

I am a complete neophyte to Netflify and rather new to Hugo, too.

I had what appeared to be a successful deployment, but I see only the “front” page of my site. There is no indication that there are other pages.

  • The site is epic-neumann-43b7b1.netlify.app.
  • I am using Hugo version 0.73.0.
  • I am using the hugo-notepadium theme.
  • I am deploying from a GitLab repo.
  • When I view the content via hugo (hugo server -D) on my own machine, all pages appear.
  • When I use hugo -D on the command line on my machine, the output indicates 14 pages. However, the Netlify deployment log reports 7 pages.

Here's a phenomenon that I discovered upon investigation: in the deployed page, there are many double-quotes (") missing. I think that the content inside double-quotes is sometimes retained, sometimes not. For example, I found the following in the deployed page: <a class="site home" href=/>

Now I see that the links are simply not there; a href= is present, but the double-quotes and the page-address are missing. What I don’t know is how to deploy all of the double-quotes and all of the content between pairs of double-quotes.



Thank you for any clues. Please find below the deployment log.


6:16:20 PM: Build ready to start
6:16:21 PM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
6:16:21 PM: build-image tag: v3.3.20
6:16:21 PM: buildbot version: 78b5536ab4f742c26705d3e953381b9cde6e22ef
6:16:21 PM: Fetching cached dependencies
6:16:22 PM: Starting to download cache of 254.7KB
6:16:22 PM: Finished downloading cache in 72.686776ms
6:16:22 PM: Starting to extract cache
6:16:22 PM: Failed to fetch cache, continuing with build
6:16:22 PM: Starting to prepare the repo for build
6:16:22 PM: No cached dependencies found. Cloning fresh repo
6:16:22 PM: git clone git@gitlab.com:JoeMack/hugo-content
6:16:23 PM: Preparing Git Reference refs/heads/master
6:16:26 PM: Starting build script
6:16:26 PM: Installing dependencies
6:16:26 PM: Python version set to 2.7
6:16:27 PM: v12.18.0 is already installed.
6:16:27 PM: Now using node v12.18.0 (npm v6.14.4)
6:16:27 PM: Started restoring cached build plugins
6:16:27 PM: Finished restoring cached build plugins
6:16:28 PM: Attempting ruby version 2.7.1, read from environment
6:16:29 PM: Using ruby version 2.7.1
6:16:29 PM: Using PHP version 5.6
6:16:29 PM: 5.2 is already installed.
6:16:29 PM: Using Swift version 5.2
6:16:29 PM: Installing Hugo 0.73.0
6:16:30 PM: Hugo Static Site Generator v0.73.0-428907CC/extended linux/amd64 BuildDate: 2020-06-23T16:40:09Z
6:16:30 PM: Started restoring cached go cache
6:16:30 PM: Finished restoring cached go cache
6:16:30 PM: go version go1.14.4 linux/amd64
6:16:30 PM: go version go1.14.4 linux/amd64
6:16:30 PM: Installing missing commands
6:16:30 PM: Verify run directory
6:16:31 PM: ​
6:16:31 PM: ┌─────────────────────────────┐
6:16:31 PM: │ Netlify Build │
6:16:31 PM: └─────────────────────────────┘
6:16:31 PM: ​
6:16:31 PM: ❯ Version
6:16:31 PM: @netlify/build 2.0.27
6:16:31 PM: ​
6:16:31 PM: ❯ Flags
6:16:31 PM: deployId: 5f0645b4ff8214747480fb86
6:16:31 PM: mode: buildbot
6:16:31 PM: ​
6:16:31 PM: ❯ Current directory
6:16:31 PM: /opt/build/repo
6:16:31 PM: ​
6:16:31 PM: ❯ Config file
6:16:31 PM: /opt/build/repo/netlify.toml
6:16:31 PM: ​
6:16:31 PM: ❯ Context
6:16:31 PM: production
6:16:32 PM: ​
6:16:32 PM: ┌────────────────────────────────────┐
6:16:32 PM: │ 1. build.command from netlify.toml │
6:16:32 PM: └────────────────────────────────────┘
6:16:32 PM: ​
6:16:32 PM: $ hugo --gc --minify
6:16:32 PM: Building sites …
6:16:32 PM: | EN
6:16:32 PM: -------------------±----
6:16:32 PM: Pages | 7
6:16:32 PM: Paginator pages | 0
6:16:32 PM: Non-page files | 0
6:16:32 PM: Static files | 5
6:16:32 PM: Processed images | 0
6:16:32 PM: Aliases | 3
6:16:32 PM: Sitemaps | 1
6:16:32 PM: Cleaned | 0
6:16:32 PM: Total in 54 ms
6:16:32 PM: ​
6:16:32 PM: (build.command completed in 115ms)
6:16:32 PM: ​
6:16:32 PM: ┌─────────────────────────────┐
6:16:32 PM: │ Netlify Build Complete │
6:16:32 PM: └─────────────────────────────┘
6:16:32 PM: ​
6:16:32 PM: (Netlify Build completed in 152ms)
6:16:32 PM: Caching artifacts
6:16:32 PM: Started saving build plugins
6:16:32 PM: Finished saving build plugins
6:16:32 PM: Started saving pip cache
6:16:32 PM: Finished saving pip cache
6:16:32 PM: Started saving emacs cask dependencies
6:16:32 PM: Finished saving emacs cask dependencies
6:16:32 PM: Started saving maven dependencies
6:16:32 PM: Finished saving maven dependencies
6:16:32 PM: Started saving boot dependencies
6:16:32 PM: Finished saving boot dependencies
6:16:32 PM: Started saving go dependencies
6:16:32 PM: Finished saving go dependencies
6:16:34 PM: Build script success
6:16:34 PM: Starting to deploy site from ‘public’
6:16:34 PM: Creating deploy tree
6:16:34 PM: Creating deploy upload records
6:16:34 PM: 0 new files to upload
6:16:34 PM: 0 new functions to upload
6:16:35 PM: Starting post processing
6:16:35 PM: Post processing - HTML
6:16:35 PM: Post processing - redirect rules
6:16:35 PM: Post processing - header rules
6:16:35 PM: Post processing done
6:16:35 PM: Site is live
6:16:49 PM: Finished processing build request in 27.501256145s

I found a solution. I had failed to change draft: true to draft: false in the post files. Once I performed that change and re-deployed, I was able to reach and view each post.

As I mentioned, I am a Netlify neophyte.

2 Likes

Congrats on figuring it out even though you are just a beginner! I’m sure this will help someone else in the same situation as you! :muscle: