Submitted Form Not Appearing In Verified or Spam Submission Sections

I’ve tested my form multiple times and the submitted form never appears in either the Verified or Spam Submission sections.

I read the debugging guide and gave my form a name (contactForm) using the Name attribute. Previously the form’s ID was being displayed as the form’s name in the Active forms dashboard. I also set up my own Thank You page, and after pressing the Submit button I do see my Thank You page (as expected), and I do not see any error messages.

When I read the condition that inputs can’t have the same name, I changed the “input” tag that I was using to be a “button” tag for my “Next” and “Previous” buttons. My form has multiple stages. I am using JavaScript but only for field validation.

I do have radio buttons that are inputs with the same name but they must have the same name to be grouped together. Not sure what to do from here.
My form was coded by me.

Here is the url to my form.

The URL to my site

I have not set up a custom domain yet.

Hey @jcoldrick,
I just filled out the form to test and was able to verify in our database that your site received the submission. Maybe you’ve gotten this working since writing in originally? Please let us know if that’s not the case!

Hi Jen, Thank you for testing my form. No, I’ve done nothing since submitting support request. I’m very happy to see it’s working now. Thanks again for replying to my support issue. I have been working on my site but nothing with the form.

Hi Jen,
I just tested my form twice using my laptop and neither showed up in the Submissions page. For the 2nd attempt today, I entered in different info and it still nothing.
Then I tested the form on my phone and it works. Strange.

Hey @JColdrick,
Very strange! I can confirm that our database “sees” your submission from your iPhone. Are you using Firefox on your laptop? If so, I wonder if you’re running into what’s described in this post:

Another thing worth checking: any browser extensions that could be interfering? Any errors in the browser’s dev console?

Hi Jen,
I had been using Chrome to test my form. I just did the form again twice: once in Chrome and once in Firefox and neither appears in the Verified Submissions list. I do see an error message in the dev console after I enter information into the first field on my last page of the form. The error says something like “Submit not defined…” Both browsers displayed similar error messages when I entered data into that 1st text box. When I finish entering info into the remaining 2 text fields and press the Submit button, all errors clear and both consoles are empty.

Which browser extensions might causes issues?

More info: I just completed the form using Safari on my desktop and it worked. I just received a notification saying that my form was submitted.

Hey @JColdrick,
I just tested from Safari on iOS and can confirm we received the submission. And tested from Chrome, confirming that we did NOT receive the submission! So at this point, we have:


  • Safari, iOS (Netlify test)
  • Firefox, desktop (Netlify test)
  • Safari, desktop (your test)

not working

  • Chrome, iOS (your test)
  • Chrome, desktop (your test)
  • Chrome, desktop (Netlify test)
  • Firefox, desktop (your test)

I also managed to capture this error: An invalid form control with name='form__businessWebsite' is not focusable in the Chrome dev console. It seems like this is a Chrome error, which prevents your form from being submitted. Do you want to try some of the suggested fixes in these posts and let us know how it goes for you?

Thanks Jen. I will read these and see if their suggestions fixes the issue with Chrome. I’m happy to learn Firefox worked at your end because it doesn’t when I use it. It behaves similar to Chrome.
We can add Safari iOS (my test) to the working list.

The error you mention flashes for less than a second on the console’s display. I had to do a screen recording just to catch it. Thanks for bringing it to my attention.

This issue is a head scratcher.

My input field is focusable and yet I still see this error in the console even after entering information into this input field. I’m unclear how it can be considered “not focusable” when you can input data into this field.

This input field is not hidden nor is it ever hidden so my issue seems different to the cases at stackoverflow.

I did see one solution stating to add “novalidate” to the form tag, and that does seem to work for both Chrome and Firefox. I just tested my form using both browsers and both test forms showed up in the Netlify Form Submission page.

I was hoping to use these browser’s internal validation but I’m at a loss on how.

I’m certainly open to any additional suggestions.

Thanks again for your attention and help with my issue.

Hi, @JColdrick, our support team limits our technical support to questions about Netlify itself. Questions about third-party or custom code are rarely something we will have time to assist with.

Someone else may be able to answer here but our support team must focus on issues which are specific to Netlify as covered in our scope of support.

To summarize, while this question is welcome, it is not Netlify specific and therefore our support will be unlikely to follow-up.

1 Like