Strange :splat added to URL in Chrome Desktop

Hi all. Getting strange redirect.

https://valticus.pro/posts/how-to-get-macos-font-rendering-in-windows/:splat

It only shows on Desktop in Chrome. Chrome (Incognito), Edge and IE show this URL fine

and so does Chrome mobile.

What could be wrong?

I don’t use Chrome so cannot directly replicate (doesn’t happen with Firefox, Opera or Safari.) What redirect rules are configured on your site?

1 Like

Hi, @ValPaliy. I believe you have fix this already.

The root cause was a redirect rule that used a :splat in the target but there was wildcard (no * character) in the destination. Please take a look at these two redirects as examples.

Rule with a wildcard:

https://example.com/old-posts/* https://example.com/posts/:splat 301!

Rule without a wildcard:

https://example.com/old-posts/ https://example.com/posts/:splat 301!

That first rule will redirect:

  • from: https://example.com/old-posts/post-1
  • to: https://example.com/posts/post-1

and:

  • from: https://example.com/old-posts/
  • to: https://example.com/posts/

However, the second rule without the wildcard will redirect:

  • from: https://example.com/old-posts/
  • to: https://example.com/posts/:splat

Again, though, you seem to have discovered this on your own. I’m just sharing the solution in case someone else find this topic.

1 Like

Thank you for taking your time to look into this issue! That’s the thing. I have no splat redirects. And the problem is still there for me in Chrome, while every other browser is fine with that page, even Chrome in incognito. Very strange.

I’ve downloaded Chrome an cannot replicate this. What are the steps you are taking @ValPaliy that causes this?

1 Like

No steps. I just try to open the URL with Chrome and 404 happens. If I go to .netlify.app instead of the domain, it does not happen.

I’ve tried

# Primary domain
https://valticus.pro/posts/how-to-get-macos-font-rendering-in-windows/
# Domain alias
https://www.valticus.pro/posts/how-to-get-macos-font-rendering-in-windows/
# Netlify subdomain
https://valticus.netlify.app/posts/how-to-get-macos-font-rendering-in-windows/

In all cases, I see no :splat appear on the end of the URL.

As Chrome Incognito is fine (but not Chrome), I suggest you look at the browser history.

1 Like

Thank you. So far I have tried clearing cache and disabling extensions. Still see the :splat :bump:

After clearing browser data a couple of times it’s working as intended. Still not sure why the :splat happened in the first place. Thanks to everyone who helped!