SOA Error on setting the DNS record of my domain provider

I’m trying to setup the domain to be managed by Netlify, and an important step is to set the correct name servers:

When I try to set these on my domain provider, the regcheck shows an error:

M-SOAR -E- [] SOA error at over TCP

You may verify the settings using this site:

What can I do to correct the SOA record?


I suspect this is an issue you are better discussing with the registrar as it is their system that is giving you the error, not Netlify’s.

I tried that, but they wrote I cannot set these nameservers until the nameserver provider accepts / setup my domain to run regcheck without any error.

And the new SOA record must be configured on Netlify I believe. I tried to config some A records, like, etc… but it didn’t help.

I believe I cannot configure the SOA record for myself, nor my domain provider can configure it.

Please, note, I setup other name servers with the same provider without any issues.

Both my domain provider as well as NS1 IBM keep telling me to contact Netlify to register the correct SOA record.

Hi, @balazsnemeth. the DNS is returning this SOA record:		3600	IN	SOA 1682496524 43200 7200 1209600 3600

There is no way to modify that SOA type DNS record. If your registrar won’t accept that as the SOA record then the solution is this:

If that doesn’t resolve the issue or if there are other questions, please let us know.

1 Like