Slow deploy times

I’ve been seeing very slow deploy times with my site - www-jvt-me is the site ID.

I’ve been seeing consistently > 4-5 minute deploy times after the site has built and I was wondering if there was anything that could help, given this is slowing me publishing things, as well as maybe incurring further cost?

hi there, could you link us to or paste a build log please? i’d like to see where the slowdown is happening.

given that we are on a globally shared build network, you will definitely see slower deploy times during peak hours.

you might check these articles:

Sure thing https://app.netlify.com/teams/jamietanna/builds/600b1b443a18d50008acb1e4

Hi, @jamietanna. There are 24,263 files in that deploy. Our forms processor examines all of those files which are HTML for the presence of <form> tags. Your site isn’t using forms so disabling that post-processing would likely greatly improve the post-processing time by no longer examining each file for forms.

There are instructions about how to do so here:

If this doesn’t improve the post-processing time or if there are other questions, please let us know.

Thanks that appears to have done it :clap:t4: I’m sorry I didn’t reach out earlier to work out what was going wrong :upside_down_face:

Hi @luke , after a new (incremental) build only changing a couple of files, would the form processing - when active - still examine all files? Just wondering.

to the best of my knowledge, it would only re-process forms that had been added or changed - we detect those by scanning through your site for html tags indicating forms are present as part of our build process.