Home
Support Forums

Site is live, but sill blank screen (react app)

How does the site work locally when you run it?

1 Like

Could be because you’re referring to an asset that’s no longer available. Does the site work locally on your computer?

1 Like

image
the value is already “/”

my site locally runs fine, the problem is when i upload it to github, i assume there is a problem with the “POST” method so i tried netlify but here it shows a blank screen, ill check if all assest called are available.

You know what, this netflix project has given me a lot of trouble when deploying it so i gave up on it because 2 reasons:
its a tutorial project, im not gonna use it in my portfolio anyway although its complete, and second, im gonna create a project on my own that includes firebase as a replacement.
Thanks for trying to help me but ive spent too much time fixing this site and i need to focus on other projects.

Thanks for following up and letting us know, @AlbertoCastroF. Should you resolve this issue in the future, don’t hesitate to come back and share your steps on this thread. Good luck!

1 Like

Hi everyone. I’m also encountering a blank screen. My netlify site URL is https://cosmophenomenology.netlify.app and my Github repository URL is https://github.com/astral-monad/react-app.

I’ve tried setting my homepage to . in the package.json but that does not work.

Hi @westher0870,

The website appears to load fine. Have you fixed this?

Hi everyone. I’m also encountering a blank screen. My netlify site URL is https://portfolio-linde.netlify.app/ and my Github repository URL is https://github.com/andersonszdc/Portfolio-linde .

I tried deploying one more time and the issue was fixed. I’m not sure what the issue was before!

Your website seems to have some errors in the console:

Maybe if you can fix that, the website will load.

but in development there aren’t this errors. How can i do?

Could you run a production build locally (npm run build) and check if the issue exists or not?

I deploy in Heroku and it is working well, https://portfolio-linde.herokuapp.com/

That’s great to know that it worked on Heroku.

But, I just tried your repo locally and it doesn’t work there either:

I faced same issue but in my case the problem was that I was trying to connect to a server with sockets with insecure protocol, so If your app connect to a server try using wss instead of ws

Thanks for sharing this, @YashuaPervez! We appreciate it!