Setting iCloud+ up with my domain; SPF issue

Hi, I am trying to setup my dns to be used for email on iCloud. I run into an issue with SPF, even though I have tried setting it up as a TXT and another time as SPF.

iCloud instructions say to set the value as ““v=spf1”” so I tried with and without the quote marks.

Any help is greatly appreciated.

Happy Holidays!

I solved it using txt record not SPF, and without the double quotes around the value.


Hey, I’m having the same issue - did you use single quotes or no quotes at all? Everything I’m trying seems to throw the same “Check your SPF record” issue with Apple. Thanks!

hi, I’m having the same problem.
I’ve tried SPF, TXT records, values with quotes, without quotes, the alternate redirect directive from the German Apple support page (“v = spf1 redirect”) Bestehende Domain mit iCloud Mail einrichten - Apple Support (DE)

all the while getting the “check your SPF record” response from apple

SPF is telling me everything is ok when I create a txt record and enter the value

v=spf1 ~all

no quotes or anything.

I’ll now wait an hour for any apple caches to clear and hope no-one sends me an email in that time…

1 Like

Hey @a23ccaf30b7b4bee3f3a

It takes time for DNS records to propagate—anything up to 48 hours—so you may just need to wait a little longer.
If you are still having issues, can you provide the domain you are setting these records for.

For icloud+ custom domain, _dmarc is required.

v=DMARC1; p=reject; exact value TXT 3600 _dmarc.<your.domain>
sig1.dkim.<your.domain> exact value CNAME 3600 sig1._domainkey.<your.domain>
v=spf1 ~all exact value TXT 3600 (already mentioned)
apple-domain=<id> exact value TXT 3600 (I was able to do this from my phone and netlify DNS console on my desktop).

1 Like