Secure Connection Failed, 2 times this month!


I have my website hosted on Netlify ( or

Recently when I tried to access my website, there was an error saying that Secure Connection failed. So I tried to fix the issue by clicking on Renew Certificate and then the issue was resolved after a day. My website was back live. But today when I tried to access my website again, the same issue popped up (Secure Connection Failed). It happened 2 times this month and Im not sure what the issue is.

I hope to hear back from someone! Thanks in advance

Hi, @huiyeon5, and welcome to the Netlify community site. :slight_smile:

We need additional details to troubleshoot.

Normally I would ask you to send us the x-nf-request-id header which we send with every HTTP response.

There more information about this header here:

That header probably isn’t available if the SSL negotiation failed. If this header isn’t available (and it probably isn’t), please send the information below (or as many of these details as possible):

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

This will help us to research the HTTP requests with failing SSL negotiation.

Hi Luke!

Thanks for your reply.

Usually I would type “” then it would redirect to the HTTPS website but seems like now it goes to So these results of the requests.

  1. Going to “ x-nf-request-id not found
  • URL -
  • IP Address for the the system -
  • Remote Address: ( Not too sure if this is the correct address)
  • Day - 03/03/2020
  • Time - 11AM
  • Timezone - Singapore Standard Time (GMT +8)
  1. Going to
    No response found.

I’m not seeing any HTTP requests for or to this IP address ( ) in the three hours before or after 2020-03-03 03:00 UTC.

The no response could indicate a network issue. The next time this occurs, it would be helpful to get a traceroute command for the IP address returned. For example, this is how I perform the DNS lookup and traceroute on MacOS:

$ nslookup

Non-authoritative answer:

$ traceroute -n
traceroute to (, 64 hops max, 52 byte packets
 1  0.601 ms  0.234 ms  0.185 ms
 2  10.756 ms  11.914 ms  16.032 ms
 3  12.949 ms  12.008 ms  12.964 ms
 4  14.018 ms  17.111 ms  12.956 ms
 5  14.399 ms  13.615 ms  13.874 ms
 6  * * *
 7  71.885 ms  27.963 ms  28.734 ms
 8  * * *
 9  * * *
10  28.336 ms !Z  32.944 ms !Z  37.015 ms !Z

This may help to highlight a connectivity issue occurring at the network level.

Note, I’m not able to research the IPV4 or IPv6 addresses in the screenshot as those are private IP addresses which will never be routed over the internet. They will be translated to a public IP address once they leave the private network and that public IP address is the only IP address we see at Netlify can see. Do you know what the public IP address is/was?

Hi Luke,

I realised that only when I access the website from my university internet, it gives an error. On other networks, I can access the website!

I tried the traceroute, on my university website

$ nslookup

Non-authoritative answer:
Address: 2400:6180:0:d1::4df:d001

$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  4.776 ms  4.661 ms  4.597 ms
 2  5.494 ms  6.554 ms  6.515 ms
 3  33.059 ms  33.026 ms  32.973 ms
 4  5.393 ms  6.479 ms  6.402 ms
 5  6.361 ms  6.308 ms  6.253 ms
 6  6.202 ms  3.380 ms  3.302 ms
 7  3.274 ms  3.168 ms  3.118 ms
 8  3.689 ms  3.654 ms  4.501 ms
 9  4.497 ms  4.457 ms  4.435 ms
10  5.411 ms  5.404 ms  4.555 ms
11  5.710 ms  5.686 ms  5.648 ms
12  5.938 ms !X  5.131 ms !X  5.096 ms !X

The above is the output I got.

Also, I got the public IP for the network Im using through this website called and following is the output

Thanks for the help!

1 Like