Runtime.ImportModuleError - Error: Cannot find module 'styled-jsx/style'

@jmarroyave, no version of the plugin is supposed to solve this currently.

Downgrading to 13.4.19 also solved the issue for me… Thank you

I’ve exhausted all available options, but the issue persists. Does anyone have information on when this will be resolved or any alternative solutions? I even attempted to downgrade Next.js to version 13.4.19, and now I’m encountering this error.

The report is pretty inactionable with the site name masked. Let us know if you can share the site name and we can check.

I’ve run into this as well. Unfortunately we can’t upgrade next past 13.4.12 as any version of 13.4 after that breaks fallback rewrites, and any version of 13.5 as the issue in this post. Would love to hear any updates or if the issue I created back in August has been even viewed about this: [Bug]: Next fallback rewrites stopped working as of next 13.4.13 · Issue #2284 · netlify/next-runtime · GitHub

I apologize for any confusion. If you want to check the build, please visit https://security.brandboostup.in. It should redirect to a 400 error, but it’s currently going to a 500 error. I resolved this by downgrading to the previous version to (13.4.19). This just worked. I also cleared my cache and rebuilt the project.

On the latest version of ‘next,’ this error is occurring, and I believe there is currently no resolution available.

Runtime.ImportModuleError: Error: Cannot find module 'styled-jsx/style'
Require stack:

Yup, we currentlyexpect this error if you use next.js 13.5 or greater with our next-runtime. Please use v 13.4.19 for the moment as it works well and will note show this error.

We are overhauling our next.js support and will have a fix for this in coming weeks (and also a lot of other missing features will become supported at the same time :slight_smile: )

1 Like

i’m still experiencing this, is there any fix? latest next.js (v14) + latest netlify next plugin does not work.

No fix yet. Please wait.

This is the best answer in this thread…

1 Like

I tried using 13.4.19 and link prefetching stopped working (it returned 404), so I went back to 13.4.9 which is the last version that seems to work with no issues (that I know of). I hope this saves somebody some time.

Is there any update? Still waiting until I can update my packages.

Welcome to the community @fleur :wave:

Next Runtime v5 is currently in beta, with the release candidate dropping sometime in the upcoming weeks which has resolved this issue.

1 Like