Home
Support Forums

Prebuild node gyp error

Hey guys need help with my build. It’s failin for some odd reason with node gyp. It previously didnt fail but today it did.
site name is clinicplusbooking and is live at www.clinicplusbooking.co.za

here is my full build log, please help.

I have set the NODE_VERSION environment variable and have added a .nvmrc file
I’m using version v10.22.0 of node js

my site is a gatsby site with “gatsby-plugin-sass”: “^2.2.1” and “node-sass”: “^4.13.1” which uses node-gyp module

4:10:01 PM: Build ready to start
4:10:03 PM: build-image version: 6a1f7e52d9cf33642526245391bde1af7845fc53 (xenial)
4:10:03 PM: build-image tag: v3.10.0
4:10:03 PM: buildbot version: 15524a3b58bf754f0d39869e5258d4b3f3eeeb5b
4:10:03 PM: Fetching cached dependencies
4:10:03 PM: Failed to fetch cache, continuing with build
4:10:03 PM: Starting to prepare the repo for build
4:10:06 PM: No cached dependencies found. Cloning fresh repo
4:10:06 PM: git clone git@gitlab.com:clinicplus1/clinicplus-booking
4:10:14 PM: Preparing Git Reference refs/heads/master
4:10:15 PM: Parsing package.json dependencies
4:10:16 PM: Starting build script
4:10:16 PM: Installing dependencies
4:10:16 PM: Python version set to 2.7
4:10:17 PM: Attempting node version 'v10.22.0' from .nvmrc
4:10:18 PM: Downloading and installing node v10.22.0...
4:10:18 PM: Downloading https://nodejs.org/dist/v10.22.0/node-v10.22.0-linux-x64.tar.xz...
4:10:18 PM: Computing checksum with sha256sum
4:10:18 PM: Checksums matched!
4:10:21 PM: Now using node v10.22.0 (npm v6.14.6)
4:10:21 PM: Started restoring cached build plugins
4:10:21 PM: Finished restoring cached build plugins
4:10:21 PM: Attempting ruby version 2.7.1, read from environment
4:10:22 PM: Required ruby-2.7.1 is not installed - installing.
4:10:22 PM: Searching for binary rubies, this might take some time.
4:10:23 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
4:10:23 PM: Checking requirements for ubuntu.
4:10:23 PM: Requirements installation successful.
4:10:23 PM: ruby-2.7.1 - #configure
4:10:23 PM: ruby-2.7.1 - #download
4:10:24 PM: ruby-2.7.1 - #validate archive
4:10:29 PM: ruby-2.7.1 - #extract
4:10:31 PM: ruby-2.7.1 - #validate binary
4:10:31 PM: ruby-2.7.1 - #setup
4:10:32 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
4:10:32 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems........................................
4:10:33 PM: ruby-2.7.1 - #generating global wrappers........
4:10:33 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
4:10:33 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
4:10:33 PM: ruby-2.7.1 - #generating default wrappers........
4:10:34 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
4:10:34 PM: Using ruby version 2.7.1
4:10:35 PM: Using PHP version 5.6
4:10:35 PM: Started restoring cached node modules
4:10:35 PM: Finished restoring cached node modules
4:10:35 PM: Installing NPM modules using NPM version 6.14.6
4:10:37 PM: npm WARN deprecated axios@0.20.0: Critical security vulnerability fixed in v0.21.1. For more information, see https://github.com/axios/axios/pull/3410
4:10:38 PM: npm WARN deprecated gatsby-image@2.11.0: This package has been deprecated in favor of gatsby-plugin-image. The migration guide can be found here: https://www.gatsbyjs.com/docs/reference/release-notes/image-migration-guide/.
4:10:42 PM: npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
4:10:42 PM: npm WARN deprecated svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x.x.
4:10:42 PM: npm WARN deprecated @hapi/joi@15.1.1: Switch to 'npm install joi'
4:10:42 PM: npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
4:10:43 PM: npm WARN deprecated eslint-loader@2.2.1: This loader has been deprecated. Please use eslint-webpack-plugin
4:10:44 PM: npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
4:10:46 PM: npm WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
4:10:48 PM: npm WARN deprecated @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
4:10:48 PM: npm WARN deprecated @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
4:10:48 PM: npm WARN deprecated @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
4:10:48 PM: npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
4:10:51 PM: npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
4:10:52 PM: npm WARN deprecated querystring@0.2.1: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
4:10:52 PM: npm WARN deprecated har-validator@5.1.5: this library is no longer supported
4:10:52 PM: npm WARN deprecated tar@2.2.2: This version of tar is no longer supported, and will not receive security updates. Please upgrade asap.
4:10:52 PM: npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
4:10:57 PM: npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
4:10:57 PM: npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
4:10:58 PM: npm WARN deprecated core-js@1.2.7: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
4:11:04 PM: npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
4:11:04 PM: npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
4:12:16 PM: > sharp@0.27.2 install /opt/build/repo/node_modules/sharp
4:12:16 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
4:12:19 PM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.10.5/libvips-8.10.5-linux-x64.tar.br
4:12:21 PM: > gl@4.9.2 install /opt/build/repo/node_modules/gl
4:12:21 PM: > prebuild-install || node-gyp rebuild
4:12:23 PM: prebuild-install WARN install /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/build/repo/node_modules/gl/build/Release/webgl.node)Package xi was not found in the pkg-config search path.
4:12:23 PM: Perhaps you should add the directory containing `xi.pc'to the PKG_CONFIG_PATH environment variableNo package 'xi' foundgyp: Call to 'pkg-config --libs-only-l x11 xi xext' returned exit status 1 while in angle/src/angle.gyp. while loading dependencies of binding.gyp while trying to load binding.gyp
4:12:23 PM: gyp ERR! configure error
4:12:23 PM: gyp ERR! stack Error: `gyp` failed with exit code: 1
4:12:23 PM: gyp ERR! stack     at ChildProcess.onCpExit (/opt/buildhome/.nvm/versions/node/v10.22.0/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
4:12:23 PM: gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
4:12:23 PM: gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
4:12:23 PM: gyp ERR! System Linux 4.19.167+
4:12:23 PM: gyp ERR! command "/opt/buildhome/.nvm/versions/node/v10.22.0/bin/node" "/opt/buildhome/.nvm/versions/node/v10.22.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
4:12:23 PM: gyp ERR! cwd /opt/build/repo/node_modules/gl
4:12:23 PM: gyp ERR! node -v v10.22.0
4:12:23 PM: gyp ERR! node-gyp -v v5.1.0
4:12:23 PM: gyp ERR! not ok
4:12:26 PM: npm WARN notsup Unsupported engine for gatsby-plugin-google-gtag@3.14.0: wanted: {"node":">=12.13.0"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: gatsby-plugin-google-gtag@3.14.0
4:12:26 PM: npm WARN notsup Unsupported engine for gatsby-plugin-google-tagmanager@3.14.0: wanted: {"node":">=12.13.0"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: gatsby-plugin-google-tagmanager@3.14.0
4:12:26 PM: npm WARN notsup Unsupported engine for gl@4.9.2: wanted: {"node":">=12.0.0"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: gl@4.9.2
4:12:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.2 (node_modules/chokidar/node_modules/fsevents):
4:12:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
4:12:26 PM: npm WARN notsup Unsupported engine for value-or-promise@1.0.6: wanted: {"node":">=12"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: value-or-promise@1.0.6
4:12:26 PM: npm WARN notsup Unsupported engine for meros@1.1.4: wanted: {"node":">=12"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: meros@1.1.4
4:12:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/watchpack-chokidar2/node_modules/chokidar/node_modules/fsevents):
4:12:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
4:12:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/webpack-dev-server/node_modules/chokidar/node_modules/fsevents):
4:12:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
4:12:26 PM: npm WARN notsup Unsupported engine for commander@8.3.0: wanted: {"node":">= 12"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: commander@8.3.0
4:12:26 PM: npm WARN notsup Unsupported engine for commander@8.3.0: wanted: {"node":">= 12"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: commander@8.3.0
4:12:26 PM: npm WARN notsup Unsupported engine for commander@8.3.0: wanted: {"node":">= 12"} (current: {"node":"10.22.0","npm":"6.14.6"})
4:12:26 PM: npm WARN notsup Not compatible with your version of node/npm: commander@8.3.0
4:12:26 PM: npm WARN gatsby-plugin-google-gtag@3.14.0 requires a peer of gatsby@^3.0.0-next.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN gatsby-plugin-google-tagmanager@3.14.0 requires a peer of gatsby@^3.0.0-next.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN react-data-components@1.2.0 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN segmented-control@0.1.17 requires a peer of react@^17.0.1 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN segmented-control@0.1.17 requires a peer of react-dom@^17.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN slick-carousel@1.8.1 requires a peer of jquery@>=1.8.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN @typescript-eslint/eslint-plugin@2.34.0 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN @typescript-eslint/parser@2.34.0 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN eslint-config-react-app@5.2.1 requires a peer of eslint@6.x but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN eslint-loader@2.2.1 requires a peer of eslint@>=1.6.0 <7.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN eslint-plugin-react-hooks@1.7.0 requires a peer of eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN tsutils@3.21.0 requires a peer of typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN ts-node@9.1.1 requires a peer of typescript@>=2.7 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm WARN recompose@0.22.0 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
4:12:26 PM: npm ERR! code ELIFECYCLE
4:12:26 PM: npm ERR! errno 1
4:12:26 PM: npm ERR! gl@4.9.2 install: `prebuild-install || node-gyp rebuild`
4:12:26 PM: npm ERR! Exit status 1
4:12:26 PM: npm ERR!
4:12:26 PM: npm ERR! Failed at the gl@4.9.2 install script.
4:12:26 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
4:12:26 PM: npm ERR! A complete log of this run can be found in:
4:12:26 PM: npm ERR!     /opt/buildhome/.npm/_logs/2021-11-03T14_12_26_176Z-debug.log
4:12:26 PM: Error during NPM install
4:12:26 PM: Build was terminated: Build script returned non-zero exit code: 1
4:12:26 PM: Creating deploy upload records
4:12:26 PM: Failing build: Failed to build site
4:12:26 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
4:12:26 PM: Finished processing build request in 2m23.153687032s

What happens with Node 14.17.5?

Thank you that worked