Package.json could not be found during build - "non-zero exit code: 254"

Netlify site name:

I am trying to deploy this project from this public github repo: GitHub - davidronnlid/drw

Deploy log:

So I went into the /clients folder of my project on GitHub to see how the package.json there was. It looked just like it was supposed to, like how it looked locally where the app worked smoothly.

This is that package.json:

  "name": "client",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@paypal/react-paypal-js": "^7.8.1",
    "@reduxjs/toolkit": "^1.8.3",
    "@testing-library/jest-dom": "^5.11.10",
    "@testing-library/react": "^11.2.6",
    "@testing-library/user-event": "^12.8.3",
    "@types/jest": "^28.1.6",
    "@types/node": "^18.6.1",
    "react": "^18.2.0",
    "react-dom": "^18.2.0",
    "react-redux": "^8.0.2",
    "react-scripts": "4.0.3",
    "web-vitals": "^1.1.1"
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  "proxy": "http://localhost:5000",
  "browserslist": {
    "production": [
      "not dead",
      "not op_mini all"
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
  "devDependencies": {
    "@types/react": "^18.0.15",
    "@types/react-dom": "^18.0.6",
    "typescript": "^4.7.4"

Why is it not loaded? Does it have something to do with my build settings or with the package.json I have in the parent directory where my single-file server is also located?

Here is that parent folder package.json:

  "name": "drw",
  "version": "1.0.0",
  "description": "",
  "main": "server.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "node server.js",
    "server": "nodemon",
    "client": "npm start --prefix /client",
    "dev": "concurrently \"npm run server\" \"npm run client\"",
    "build": "npm run build --prefix /client"
  "keywords": [],
  "author": "",
  "license": "ISC",
  "devDependencies": {
    "concurrently": "^7.3.0",
    "nodemon": "^2.0.19"
  "dependencies": {
    "express": "^4.18.1"


You haven’t really set client as the base path: