O-Auth redirects to port 80

When trying to interact with my next-auth backend I get redirected to port 80 instead of 443

Another anomaly I’ve experienced is that I’m not getting redirected to my set url rather a netlify generated deploy url. Is there anything I’ve missed in setting things up. If I need to provide anything else for a quick solution hit me up.
Thank you!

That’s a bug with Next.js Runtime v4. Try upgrading to Runtime v5: Next.js 14 Upgrade Results in 500 Status Code - #33 by elad.rosenheim