Home
Support Forums

Nuxt & Vuetify Failed Build - can't resolve webp image

I’m a little stumped with the error I’m getting. I have a simple Nuxt site with Vuetify & nuxt/Content that I’m trying to deploy . It builds and can be deployed on a local server but fails on netlify - can’t resolve the image I use for the landing page. I’ve tried 2 paths (./…/assets/landing.webp & ~/asssets/landing.webp) but bot fail to build.

Please help.

Here is the message from the log:
12:47:34 AM: [fatal] Nuxt build error
12:47:34 AM: ERROR in ./pages/index.vue?vue&type=template&id=130bc64e&scoped=true& (./node_modules/vue-loader/lib/loaders/templateLoader.js??vue-loader-options!./node_modules/@nuxt/components/dist/loader.js??ref–0-0!./node_modules/vue-loader/lib??vue-loader-options!./pages/index.vue?vue&type=template&id=130bc64e&scoped=true&)
12:47:34 AM: Module not found: Error: Can’t resolve ‘./…/assets/landing.webp’ in ‘pages’
@ ./pages/index.vue?vue&type=template&id=130bc64e&scoped=true& (./node_modules/vue-loader/lib/loaders/templateLoader.js??vue-loader-options!./node_modules/@nuxt/components/dist/loader.js??ref–0-0!./node_modules/vue-loader/lib??vue-loader-options!./pages/index.vue?vue&type=template&id=130bc64e&scoped=true&) 1:143-178
12:47:34 AM: @ ./pages/index.vue?vue&type=template&id=130bc64e&scoped=true&
12:47:34 AM: @ ./pages/index.vue

Hi @saericson

If so, have you checked the filename case?
Have you confirmed the file(s) exist the git repository (where they pushed from your local machine)?

Are you able to share your repository so others may help debug should the above steps not work?

You nailed it! It was an upper/lower case issue. Worked locally as it’s a Win 10 box, which is careless with case in filenames.

It deployed with the fix.

Thank You!
Anders

1 Like