Home
Support Forums

Not able to deploy react app

I’m not able to deploy this app Netlify App

Hi there, glad you found us :wave:

Sorry to hear you are having deploy issues! Have you seen this Support Guide about frequently encountered issues during build? Additionally, have you searched the forums for other exit cod 127: npm run build errors?

Lastly, if you have worked through the above support guide as well as some additional forums threads, please tell us:

Please share:

  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console
  • your repo


This is the error.
Not able to figure out what to do
Repo:GitHub - RavjotSandhu/GameOfLife

Can you share your package.json as well, so that we can see the commands you are using?

{
  "name": "game-of-life",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@testing-library/jest-dom": "^5.11.4",
    "@testing-library/react": "^11.1.0",
    "@testing-library/user-event": "^12.1.10",
    "bootstrap": "^5.1.0",
    "react": "^17.0.1",
    "react-bootstrap": "^2.0.0-beta.6",
    "react-dom": "^17.0.1",
    "react-scripts": "4.0.1",
    "web-vitals": "^0.2.4"
  },
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  },
  "eslintConfig": {
    "extends": [
      "react-app",
      "react-app/jest"
    ]
  },
  "browserslist": {
    "production": [
      ">0.2%",
      "not dead",
      "not op_mini all"
    ],
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"
    ]
  }
}

Hi @RavjotSandhu

Are you still receiving the same error?

I forked your repository but I did not get the same error as you, rather

8:29:46 AM: Treating warnings as errors because process.env.CI = true.
8:29:46 AM: Most CI servers set it automatically.
8:29:46 AM: 
8:29:46 AM: Failed to compile.
8:29:46 AM: 
8:29:46 AM: src/Components/App.js
8:29:46 AM:   Line 89:6:  React Hook useEffect has a missing dependency: 'grid'. Either include it or remove the dependency array  react-hooks/exhaustive-deps
8:29:46 AM: src/Components/Box.jsx
8:29:46 AM:   Line 2:9:  'Grid' is defined but never used  no-unused-vars
8:29:46 AM: ​
8:29:46 AM: ────────────────────────────────────────────────────────────────
8:29:46 AM:   "build.command" failed                                        
8:29:46 AM: ────────────────────────────────────────────────────────────────
8:29:46 AM: ​
8:29:46 AM:   Error message
8:29:46 AM:   Command failed with exit code 1: npm run build

Changing the build command to CI='' npm run build ignores these warnings and stop them breaking to build, however I believe better to address them as you will have much better code.

My deploy is available at youthful-tesla-e835d8.netlify.app