Node incompatibility issue only on Netlify builds

Upgraded Tailwind CSS to V2.0. Followed their docs. Everything works locally and builds locally. When Netlify deploys it, build fails with error:

error @tailwindcss/postcss7-compat@2.1.0: The engine "node" is incompatible with this module. Expected version ">=12.13.0". Got "10.24.1"

I have tried deleting node modules, yarn.lock , reinstalling everything, upgrading node, playing around with tailwind packages, and nothing is working. My logs:

Resolved: Node version was out of date. Needed to specify newer node version in ENV var.

1 Like