No matching distribution found for PyYAML==6.0

Netlify URL:

Full log:

10:14:49 AM: build-image version: d55944c047ef0aee2ac01971edde72cb2a50acfe (focal)
10:14:49 AM: build-image tag: v4.16.1
10:14:49 AM: buildbot version: 0be68edd034c744ad79b207db44f42646b4e8ecb
10:14:49 AM: Fetching cached dependencies
10:14:49 AM: Failed to fetch cache, continuing with build
10:14:49 AM: Starting to prepare the repo for build
10:14:49 AM: No cached dependencies found. Cloning fresh repo
10:14:49 AM: git clone --filter=blob:none
10:14:50 AM: Preparing Git Reference refs/heads/main
10:14:50 AM: Parsing package.json dependencies
10:14:51 AM: Starting build script
10:14:51 AM: Installing dependencies
10:14:51 AM: Python version set to 2.7
10:14:51 AM: v16.19.0 is already installed.
10:14:52 AM: Now using node v16.19.0 (npm v8.19.3)
10:14:52 AM: Enabling node corepack
10:14:52 AM: Started restoring cached build plugins
10:14:52 AM: Finished restoring cached build plugins
10:14:52 AM: Attempting ruby version 2.7.2, read from environment
10:14:52 AM: Using ruby version 2.7.2
10:14:53 AM: Using PHP version 8.0
10:14:53 AM: Installing pip dependencies
10:14:53 AM: Started restoring cached pip cache
10:14:53 AM: Finished restoring cached pip cache
10:14:53 AM: DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at
10:14:53 AM: ERROR: Could not find a version that satisfies the requirement PyYAML==6.0 (from -r requirements.txt (line 1)) (from versions: 3.10, 3.11, 3.12, 3.13b1, 3.13rc1, 3.13, 4.2b1, 4.2b2, 4.2b4, 5.1b1, 5.1b3, 5.1b5, 5.1, 5.1.1, 5.1.2, 5.2b1, 5.2, 5.3b1, 5.3, 5.3.1, 5.4b1, 5.4b2, 5.4, 5.4.1)
10:14:53 AM: ERROR: No matching distribution found for PyYAML==6.0 (from -r requirements.txt (line 1))
10:14:53 AM: Error installing pip dependencies
10:14:53 AM: Build was terminated: Build script returned non-zero exit code: 1
10:14:53 AM: Failing build: Failed to build site
10:14:53 AM: Failed during stage 'building site': Build script returned non-zero exit code: 1 (
10:14:54 AM: Finished processing build request in 5.01653126s

I’m unsure why this error is only now presenting itself. If I change the requirement to PyYAML 5.4.1, I get a similar error regarding the python-slugify version.



This was previously working fine and the requirements have not changed, would anyone be able to lend a hand?

Netlify only supports a maximum of Python 3.8 currently:

However, your dependencies mention, a minimum of Python 3.10:

You’d most likely have to use an older version of the dependency along with the 3.8 version of Python.